CVE-2023-25173
CVE-2023-25173 · containerd supplementary groups are not set up properly
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
containerd is an open source container runtime. A bug was found in containerd prior to versions 1.6.18 and 1.5.18 where supplementary groups are not set up properly inside a container. If an attacker has direct access to a container and manipulates their supplementary group access, they may be able to use supplementary group access to bypass primary group restrictions in some cases, potentially gaining access to sensitive information or gaining the ability to execute code in that container. Downstream applications that use the containerd client library may be affected as well. This bug has been fixed in containerd v1.6.18 and v.1.5.18. Users should update to these versions and recreate containers to resolve this issue. Users who rely on a downstream application that uses containerd's client library should check that application for a separate advisory and instructions. As a workaround, ensure that the `"USER $USERNAME"` Dockerfile instruction is not used. Instead, set the container entrypoint to a value similar to `ENTRYPOINT ["su", "-", "user"]` to allow `su` to properly set up supplementary groups.
CVSS 5.3 · Moyenne · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · containers
Produits et versions concernés
containerd
- Versions du logiciel
- < 1.5.18: Concernée
- >= 1.6.0, < 1.6.18: Concernée
Aucun correctif publié
containerd Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.6.18~ds1-1
Mettez à jour vers 1.6.18~ds1-1
containerd Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.6.18~ds1-1
Mettez à jour vers 1.6.18~ds1-1
containerd Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.6.18~ds1-1
Mettez à jour vers 1.6.18~ds1-1
containerd Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 0.2.1-0ubuntu4~16.04
- 0.2.3-0ubuntu1~16.04
- 0.2.5-0ubuntu1~16.04.1
- 1.2.6-0ubuntu1~16.04.2
- 1.2.6-0ubuntu1~16.04.3
- 1.2.6-0ubuntu1~16.04.4
- 1.2.6-0ubuntu1~16.04.5
- 1.2.6-0ubuntu1~16.04.6
- 1.2.6-0ubuntu1~16.04.6+esm1
- 1.2.6-0ubuntu1~16.04.6+esm2
- Plages de versions concernées
- ECOSYSTEM: < 1.2.6-0ubuntu1~16.04.6+esm4
Mettez à jour vers 1.2.6-0ubuntu1~16.04.6+esm4
containerd Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 0.2.5-0ubuntu2
- 1.2.6-0ubuntu1~18.04.1
- 1.2.6-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.1
- 1.3.3-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.3
- 1.3.3-0ubuntu1~18.04.4
- 1.4.4-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.1
- 1.5.2-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.3
- 1.5.5-0ubuntu3~18.04.1
- 1.5.5-0ubuntu3~18.04.2
- 1.5.9-0ubuntu1~18.04.1
- 1.5.9-0ubuntu1~18.04.2
- 1.6.12-0ubuntu1~18.04.1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.12-0ubuntu1~18.04.1+esm1
Mettez à jour vers 1.6.12-0ubuntu1~18.04.1+esm1
containerd Ubuntu:20.04:LTS
- Versions du logiciel
- 1.2.10-0ubuntu1
- 1.3.2-0ubuntu1
- 1.3.3-0ubuntu1
- 1.3.3-0ubuntu2
- 1.3.3-0ubuntu2.1
- 1.3.3-0ubuntu2.2
- 1.3.3-0ubuntu2.3
- 1.4.4-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.1
- 1.5.2-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.3
- 1.5.5-0ubuntu3~20.04.1
- 1.5.5-0ubuntu3~20.04.2
- 1.5.9-0ubuntu1~20.04.1
- 1.5.9-0ubuntu1~20.04.4
- 1.5.9-0ubuntu1~20.04.5
- 1.5.9-0ubuntu1~20.04.6
- 1.6.12-0ubuntu1~20.04.1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.12-0ubuntu1~20.04.3
Mettez à jour vers 1.6.12-0ubuntu1~20.04.3
containerd Ubuntu:22.04:LTS
- Versions du logiciel
- 1.5.5-0ubuntu3
- 1.5.9-0ubuntu1
- 1.5.9-0ubuntu2
- 1.5.9-0ubuntu3
- 1.5.9-0ubuntu3.1
- 1.6.12-0ubuntu1~22.04.1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.12-0ubuntu1~22.04.3
Mettez à jour vers 1.6.12-0ubuntu1~22.04.3
Sources originales
- https://github.com/containerd/containerd/security/advisories/GHSA-hmfx-3pcx-653p
- https://github.com/moby/moby/security/advisories/GHSA-rc4r-wh2q-q6c4
- https://github.com/containerd/containerd/commit/133f6bb6cd827ce35a5fb279c1ead12b9d21460a
- https://github.com/advisories/GHSA-4wjj-jwc9-2x96
- https://github.com/advisories/GHSA-fjm8-m7m6-2fjp
- https://github.com/advisories/GHSA-phjr-8j92-w5v7
- https://github.com/containerd/containerd/releases/tag/v1.5.18
- https://github.com/containerd/containerd/releases/tag/v1.6.18
- https://www.benthamsgaze.org/2022/08/22/vulnerability-in-linux-containers-investigation-and-mitigation/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/ZTE4ITXXPIWZEQ4HYQCB6N6GZIMWXDAI/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/LYZOKMMVX4SIEHPJW3SJUQGMO5YZCPHC/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/XNF4OLYZRQE75EB5TW5N42FSXHBXGWFE/
- https://nvd.nist.gov/vuln/detail/CVE-2023-25173