p PatchFirst

CVE-2023-27599

CVE-2023-27599 · OpenSIPS has vulnerability in the parse_to_param() function

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, when the function `append_hf` handles a SIP message with a malformed To header, a call to the function `abort()` is performed, resulting in a crash. This is due to the following check in `data_lump.c:399` in the function `anchor_lump`. An attacker abusing this vulnerability will crash OpenSIPS leading to Denial of Service. It affects configurations containing functions that make use of the affected code, such as the function `append_hf`. This issue has been fixed in versions 3.1.7 and 3.2.4.

CVSS 7.5 · Élevée · EPSS 1,0%

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • opensips

    Versions du logiciel
    • < 3.1.7: Concernée
    • >= 3.2.0, < 3.2.4: Concernée

    Aucun correctif publié

  • opensips Ubuntu:18.04:LTS

    Versions du logiciel
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →