p PatchFirst

CVE-2023-30536

CVE-2023-30536 · Insecure header validation in slim/psr7

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

slim/psr7 is a PSR-7 implementation for use with Slim 4. In versions prior to 1.6.1 an attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. An attacker that is able to control the header names that are passed to Slilm-Psr7 would be able to intentionally craft invalid messages, possibly causing application errors or invalid HTTP requests being sent out with an PSR-18 HTTP client. The latter might present a denial of service vector if a remote service’s web application firewall bans the application due to the receipt of malformed requests. The issue has been patched in version 1.6.1. There are no known workarounds to this issue. Users are advised to upgrade.

CVSS 6.5 · Moyenne · EPSS 0,7% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · php

Produits et versions concernés

  • slim-psr7

    Versions du logiciel
    • < 1.6.1: Concernée

    Aucun correctif publié

  • php-slim-psr7 Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 1.6.1-1

    Mettez à jour vers 1.6.1-1

  • php-slim-psr7 Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.6.1-1

    Mettez à jour vers 1.6.1-1

  • php-slim-psr7 Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.6.1-1

    Mettez à jour vers 1.6.1-1

  • slim/psr7 Packagist

    Versions du logiciel
    • 1.6
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.6, < 1.6.1

    Mettez à jour vers 1.6.1

  • slim/psr7 Packagist

    Versions du logiciel
    • 1.5
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.5, < 1.5.1

    Mettez à jour vers 1.5.1

  • slim/psr7 Packagist

    Versions du logiciel
    • 0.1.0
    • 0.2.0
    • 0.3.0
    • 0.4.0
    • 0.5.0
    • 0.6
    • 1.0.0
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.4
    Plages de versions concernées
    • ECOSYSTEM: < 1.4.1

    Mettez à jour vers 1.4.1

Sources originales

Vérifiez votre serveur →