p PatchFirst

CVE-2023-30861

CVE-2023-30861 · Flask vulnerable to possible disclosure of permanent session cookie due to missing Vary: Cookie header

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Flask is a lightweight WSGI web application framework. When all of the following conditions are met, a response containing data intended for one client may be cached and subsequently sent by the proxy to other clients. If the proxy also caches `Set-Cookie` headers, it may send one client's `session` cookie to other clients. The severity depends on the application's use of the session and the proxy's behavior regarding cookies. The risk depends on all these conditions being met. 1. The application must be hosted behind a caching proxy that does not strip cookies or ignore responses with cookies. 2. The application sets `session.permanent = True` 3. The application does not access or modify the session at any point during a request. 4. `SESSION_REFRESH_EACH_REQUEST` enabled (the default). 5. The application does not set a `Cache-Control` header to indicate that a page is private or should not be cached. This happens because vulnerable versions of Flask only set the `Vary: Cookie` header when the session is accessed or modified, not when it is refreshed (re-sent to update the expiration) without being accessed or modified. This issue has been fixed in versions 2.3.2 and 2.2.5.

CVSS 7.5 · Élevée · EPSS 1,2% · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · python

Produits et versions concernés

  • flask

    Versions du logiciel
    • >= 2.3.0, < 2.3.2: Concernée
    • < 2.2.5: Concernée

    Aucun correctif publié

  • flask Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 2.2.2-3

    Mettez à jour vers 2.2.2-3

  • flask Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 2.2.2-3

    Mettez à jour vers 2.2.2-3

  • flask Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 2.2.2-3

    Mettez à jour vers 2.2.2-3

  • flask PyPI

    Versions du logiciel
    • 2.3.0
    • 2.3.1
    Plages de versions concernées
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.2

    Mettez à jour vers 2.3.2

  • flask PyPI

    Versions du logiciel
    • 0.1
    • 0.10
    • 0.10.1
    • 0.11
    • 0.11.1
    • 0.12
    • 0.12.1
    • 0.12.2
    • 0.12.3
    • 0.12.4
    • 0.12.5
    • 0.2
    • 0.3
    • 0.3.1
    • 0.4
    • 0.5
    • 0.5.1
    • 0.5.2
    • 0.6
    • 0.6.1
    • 0.7
    • 0.7.1
    • 0.7.2
    • 0.8
    • 0.8.1
    • 0.9
    • 1.0
    • 1.0.1
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 2.0.0
    • 2.0.0rc1
    • 2.0.0rc2
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    Plages de versions concernées
    • ECOSYSTEM: < 2.2.5

    Mettez à jour vers 2.2.5

  • flask PyPI

    Versions du logiciel
    • 0.1
    • 0.10
    • 0.10.1
    • 0.11
    • 0.11.1
    • 0.12
    • 0.12.1
    • 0.12.2
    • 0.12.3
    • 0.12.4
    • 0.12.5
    • 0.2
    • 0.3
    • 0.3.1
    • 0.4
    • 0.5
    • 0.5.1
    • 0.5.2
    • 0.6
    • 0.6.1
    • 0.7
    • 0.7.1
    • 0.7.2
    • 0.8
    • 0.8.1
    • 0.9
    • 1.0
    • 1.0.1
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 2.0.0
    • 2.0.0rc1
    • 2.0.0rc2
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 2.3.0
    • 2.3.1
    Plages de versions concernées
    • {"events": [{"introduced": "0"}, {"fixed": "70f906c51ce49c485f1d355703e9cc3386b1cc2b"}, {"fixed": "afd63b16170b7c047f5758eb910c416511e9c965"}], "repo": "https://github.com/pallets/flask", "type": "GIT"}
    • ECOSYSTEM: < 2.2.5 ∪ ≥ 2.3.0, < 2.3.2

    Mettez à jour vers 2.2.5; Mettez à jour vers 2.3.2

  • flask Ubuntu:20.04:LTS

    Versions du logiciel
    • 1.0.2-3
    • 1.1.1-2
    Plages de versions concernées
    • ECOSYSTEM: < 1.1.1-2ubuntu0.1

    Mettez à jour vers 1.1.1-2ubuntu0.1

  • flask Ubuntu:22.04:LTS

    Versions du logiciel
    • 1.1.2-2
    • 2.0.1-2ubuntu1
    Plages de versions concernées
    • ECOSYSTEM: < 2.0.1-2ubuntu1.1

    Mettez à jour vers 2.0.1-2ubuntu1.1

Sources originales

Vérifiez votre serveur →