p PatchFirst

CVE-2023-35005

CVE-2023-35005 · Apache Airflow: Information disclosure on configuration view

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations. This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if `[webserver] expose_config` is set to `non-sensitive-only`), and not all uncensored values are actually sentitive. This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.

CVSS 7.1 · Élevée · EPSS 1,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • apache airflow

    Versions du logiciel
    • ≥ 2.5.0, < 2.6.2: Concernée (semver)

    Mettez à jour vers 2.6.2

  • apache-airflow PyPI

    Versions du logiciel
    • 2.5.0
    • 2.5.1
    • 2.5.1rc1
    • 2.5.1rc2
    • 2.5.2
    • 2.5.2rc1
    • 2.5.2rc2
    • 2.5.3
    • 2.5.3rc1
    • 2.5.3rc2
    • 2.6.0
    • 2.6.0b1
    • 2.6.0rc1
    • 2.6.0rc2
    • 2.6.0rc3
    • 2.6.0rc4
    • 2.6.0rc5
    • 2.6.1
    • 2.6.1rc1
    • 2.6.1rc2
    • 2.6.1rc3
    Plages de versions concernées
    • ECOSYSTEM: ≥ 2.5.0, < 2.6.2rc1

    Mettez à jour vers 2.6.2rc1

  • apache-airflow PyPI

    Versions du logiciel
    • 2.5.0
    • 2.5.1
    • 2.5.1rc1
    • 2.5.1rc2
    • 2.5.2
    • 2.5.2rc1
    • 2.5.2rc2
    • 2.5.3
    • 2.5.3rc1
    • 2.5.3rc2
    • 2.6.0
    • 2.6.0b1
    • 2.6.0rc1
    • 2.6.0rc2
    • 2.6.0rc3
    • 2.6.0rc4
    • 2.6.0rc5
    • 2.6.1
    • 2.6.1rc1
    • 2.6.1rc2
    • 2.6.1rc3
    • 2.6.2rc1
    • 2.6.2rc2
    Plages de versions concernées
    • ECOSYSTEM: ≥ 2.5.0, < 2.6.2

    Mettez à jour vers 2.6.2

Sources originales

Vérifiez votre serveur →