CVE-2023-39531
CVE-2023-39531 · Sentry vulnerable to incorrect credential validation on OAuth token requests
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.
CVSS 6.5 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
sentry
- Versions du logiciel
- >= 10.0.0, < 23.7.2: Concernée
Aucun correctif publié
sentry PyPI
- Versions du logiciel
- 10.0.0
- 10.0.1
- 20.10.1
- 20.11.0
- 20.11.1
- 20.12.0
- 20.12.1
- 20.6.0
- 20.7.0
- 20.7.1
- 20.7.2
- 20.8.0
- 21.1.0
- 21.10.0
- 21.11.0
- 21.12.0
- 21.2.0
- 21.3.0
- 21.3.1
- 21.4.0
- 21.4.1
- 21.5.0
- 21.5.1
- 21.6.0
- 21.6.1
- 21.6.2
- 21.6.3
- 21.7.0
- 21.8.0
- 21.9.0
- 22.1.0
- 22.10.0
- 22.11.0
- 22.12.0
- 22.2.0
- 22.3.0
- 22.4.0
- 22.5.0
- 22.6.0
- 22.7.0
- 22.8.0
- 22.9.0
- 23.1.0
- 23.1.1
- 23.2.0
- 23.3.0
- 23.3.1
- 23.4.0
- 23.5.0
- 23.5.1
- 23.5.2
- 23.6.0
- 23.6.1
- 23.6.2
- 23.7.0
- 23.7.1
- Plages de versions concernées
- ECOSYSTEM: ≥ 10.0.0, < 23.7.2
Mettez à jour vers 23.7.2