CVE-2023-40581
CVE-2023-40581 · yt-dlp command injection when using `%q` in `--exec` on Windows
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
yt-dlp is a youtube-dl fork with additional features and fixes. yt-dlp allows the user to provide shell command lines to be executed at various stages in its download steps through the `--exec` flag. This flag allows output template expansion in its argument, so that metadata values may be used in the shell commands. The metadata fields can be combined with the `%q` conversion, which is intended to quote/escape these values so they can be safely passed to the shell. However, the escaping used for `cmd` (the shell used by Python's `subprocess` on Windows) does not properly escape special characters, which can allow for remote code execution if `--exec` is used directly with maliciously crafted remote data. This vulnerability only impacts `yt-dlp` on Windows, and the vulnerability is present regardless of whether `yt-dlp` is run from `cmd` or from `PowerShell`. Support for output template expansion in `--exec`, along with this vulnerable behavior, was added to `yt-dlp` in version 2021.04.11. yt-dlp version 2023.09.24 fixes this issue by properly escaping each special character. `\n` will be replaced by `\r` as no way of escaping it has been found. It is recommended to upgrade yt-dlp to version 2023.09.24 as soon as possible. Also, always be careful when using --exec, because while this specific vulnerability has been patched, using unvalidated input in shell commands is inherently dangerous. For Windows users who are not able to upgrade: 1. Avoid using any output template expansion in --exec other than {} (filepath). 2. If expansion in --exec is needed, verify the fields you are using do not contain ", | or &. 3. Instead of using --exec, write the info json and load the fields from it instead.
CVSS 8.4 · Élevée · EPSS 1,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
yt-dlp
- Versions du logiciel
- >= 2021.04.11, < 2023.09.24: Concernée
- < nightly 2023.09.24.003044: Concernée
Aucun correctif publié
yt-dlp PyPI
- Versions du logiciel
- 2021.10.10
- 2021.10.22
- 2021.10.9
- 2021.11.10
- 2021.11.10.1
- 2021.12.1
- 2021.12.25
- 2021.12.27
- 2021.4.11
- 2021.4.22
- 2021.5.11
- 2021.5.20
- 2021.6.1
- 2021.6.23
- 2021.6.8
- 2021.6.9
- 2021.7.21
- 2021.7.24
- 2021.7.7
- 2021.8.10
- 2021.8.2
- 2021.9.1
- 2021.9.2
- 2021.9.25
- 2022.1.21
- 2022.10.4
- 2022.11.11
- 2022.2.3
- 2022.2.4
- 2022.3.8
- 2022.3.8.1
- 2022.3.8.2
- 2022.4.8
- 2022.5.18
- 2022.6.22
- 2022.6.22.1
- 2022.6.29
- 2022.7.17
- 2022.7.18
- 2022.8.14
- 2022.8.19
- 2022.8.8
- 2022.9.1
- 2023.1.2
- 2023.1.6
- 2023.2.17
- 2023.3.3
- 2023.3.4
- 2023.6.21
- 2023.6.22
- 2023.7.6
- Plages de versions concernées
- ECOSYSTEM: ≥ 2021.04.11, < 2023.09.24
Mettez à jour vers 2023.09.24
Sources originales
- https://github.com/yt-dlp/yt-dlp/security/advisories/GHSA-42h4-v29r-42qg
- https://github.com/yt-dlp/yt-dlp/commit/de015e930747165dbb8fcd360f8775fd973b7d6e
- https://github.com/yt-dlp/yt-dlp-nightly-builds/releases/tag/2023.09.24.003044
- https://github.com/yt-dlp/yt-dlp/releases/tag/2021.04.11
- https://github.com/yt-dlp/yt-dlp/releases/tag/2023.09.24
- https://nvd.nist.gov/vuln/detail/CVE-2023-40581