p PatchFirst

CVE-2023-41879

CVE-2023-41879 · Magento LTS's guest order "protect code" can be brute-forced too easily

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Magento LTS is the official OpenMage LTS codebase. Guest orders may be viewed without authentication using a "guest-view" cookie which contains the order's "protect_code". This code is 6 hexadecimal characters which is arguably not enough to prevent a brute-force attack. Exposing each order would require a separate brute force attack. This issue has been patched in versions 19.5.1 and 20.1.1.

CVSS 7.5 · Élevée · EPSS 1,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: php

Produits et versions concernés

  • magento-lts

    Versions du logiciel
    • <= 19.5.0: Concernée
    • >= 20.0.0, <= 20.1.0: Concernée

    Aucun correctif publié

  • openmage/magento-lts Packagist

    Versions du logiciel
    • 1.9.1.1
    • 1.9.2.0
    • 1.9.2.1
    • 1.9.2.2
    • 1.9.2.3
    • 1.9.2.4
    • 1.9.3.0
    • 1.9.3.1
    • v19.4.0
    • v19.4.1
    • v19.4.10
    • v19.4.11
    • v19.4.12
    • v19.4.13
    • v19.4.14
    • v19.4.15
    • v19.4.16
    • v19.4.17
    • v19.4.18
    • v19.4.19
    • v19.4.2
    • v19.4.20
    • v19.4.21
    • v19.4.22
    • v19.4.23
    • v19.4.3
    • v19.4.4
    • v19.4.5
    • v19.4.6
    • v19.4.7
    • v19.4.8
    • v19.4.9
    • v19.5.0
    • v19.5.0-rc1
    • v19.5.0-rc2
    • v19.5.0-rc3
    • v19.5.0-rc4
    • v19.5.0-rc5
    Plages de versions concernées
    • ECOSYSTEM: < 19.5.1

    Mettez à jour vers 19.5.1

  • openmage/magento-lts Packagist

    Versions du logiciel
    • v20.0.0
    • v20.0.1
    • v20.0.10
    • v20.0.11
    • v20.0.12
    • v20.0.13
    • v20.0.14
    • v20.0.15
    • v20.0.16
    • v20.0.17
    • v20.0.18
    • v20.0.19
    • v20.0.2
    • v20.0.20
    • v20.0.3
    • v20.0.4
    • v20.0.5
    • v20.0.6
    • v20.0.7
    • v20.0.8
    • v20.1.0
    • v20.1.0-rc1
    • v20.1.0-rc2
    • v20.1.0-rc3
    • v20.1.0-rc4
    • v20.1.0-rc5
    • v20.1.0-rc6
    • v20.1.0-rc7
    Plages de versions concernées
    • ECOSYSTEM: ≥ 20.0.0, < 20.1.1

    Mettez à jour vers 20.1.1

Sources originales

Vérifiez votre serveur →