p PatchFirst

CVE-2023-45139

CVE-2023-45139 · fonttools XML External Entity Injection (XXE) Vulnerability

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

fontTools is a library for manipulating fonts, written in Python. The subsetting module has a XML External Entity Injection (XXE) vulnerability which allows an attacker to resolve arbitrary entities when a candidate font (OT-SVG fonts), which contains a SVG table, is parsed. This allows attackers to include arbitrary files from the filesystem fontTools is running on or make web requests from the host system. This vulnerability has been patched in version 4.43.0.

CVSS 7.5 · Élevée · EPSS 1,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · python

Produits et versions concernés

  • fonttools

    Versions du logiciel
    • >= 4.28.2, < 4.43.0: Concernée

    Aucun correctif publié

  • fonttools Debian:12

    Versions du logiciel
    • 4.38.0-1
    Plages de versions concernées
    • ECOSYSTEM: < 4.38.0-1+deb12u1

    Mettez à jour vers 4.38.0-1+deb12u1

  • fonttools Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 4.46.0-1

    Mettez à jour vers 4.46.0-1

  • fonttools Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 4.46.0-1

    Mettez à jour vers 4.46.0-1

  • fonttools PyPI

    Versions du logiciel
    • 4.28.2
    • 4.28.3
    • 4.28.4
    • 4.28.5
    • 4.29.0
    • 4.29.1
    • 4.30.0
    • 4.31.0
    • 4.31.1
    • 4.31.2
    • 4.32.0
    • 4.33.0
    • 4.33.1
    • 4.33.2
    • 4.33.3
    • 4.34.0
    • 4.34.1
    • 4.34.2
    • 4.34.3
    • 4.34.4
    • 4.35.0
    • 4.36.0
    • 4.37.0
    • 4.37.1
    • 4.37.2
    • 4.37.3
    • 4.37.4
    • 4.38.0
    • 4.38.1.dev0
    • 4.39.0
    • 4.39.1
    • 4.39.2
    • 4.39.3
    • 4.39.4
    • 4.40.0
    • 4.41.0
    • 4.41.1
    • 4.42.0
    • 4.42.1
    Plages de versions concernées
    • ECOSYSTEM: ≥ 4.28.2, < 4.43.0

    Mettez à jour vers 4.43.0

  • fonttools Ubuntu:Pro:22.04:LTS

    Versions du logiciel
    • 4.23.1-1
    • 4.27.1-1
    • 4.28.3-1
    • 4.28.5-1
    • 4.29.1-1
    • 4.29.1-2build1
    Plages de versions concernées
    • ECOSYSTEM: < 4.29.1-2ubuntu0.1~esm1

    Mettez à jour vers 4.29.1-2ubuntu0.1~esm1

Sources originales

Vérifiez votre serveur →