CVE-2023-46118
CVE-2023-46118 · Denial of Service by publishing large messages over the HTTP API
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
RabbitMQ is a multi-protocol messaging and streaming broker. HTTP API did not enforce an HTTP request body limit, making it vulnerable for denial of service (DoS) attacks with very large messages. An authenticated user with sufficient credentials can publish a very large messages over the HTTP API and cause target node to be terminated by an "out-of-memory killer"-like mechanism. This vulnerability has been patched in versions 3.11.24 and 3.12.7.
CVSS 4.9 · Moyenne · EPSS 1,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · database
Produits et versions concernés
rabbitmq
- Versions du logiciel
- < 3.12.7: Concernée
- < 3.11.24: Concernée
Aucun correctif publié
rabbitmq-server Debian:12
- Versions du logiciel
- 3.10.8-1.1
- Plages de versions concernées
- ECOSYSTEM: < 3.10.8-1.1+deb12u1
Mettez à jour vers 3.10.8-1.1+deb12u1
rabbitmq-server Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 3.10.8-3
Mettez à jour vers 3.10.8-3
rabbitmq-server Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 3.10.8-3
Mettez à jour vers 3.10.8-3
rabbitmq-server Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 3.5.4-1
- 3.5.4-3
- 3.5.4-3.1
- 3.5.7-1
- 3.5.7-1ubuntu0.16.04.1
- 3.5.7-1ubuntu0.16.04.2
- 3.5.7-1ubuntu0.16.04.4
- 3.5.7-1ubuntu0.16.04.4+esm1
- 3.5.7-1ubuntu0.16.04.4+esm2
- 3.5.7-1ubuntu0.16.04.4+esm3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
rabbitmq-server Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 3.6.10-1
- 3.6.10-1ubuntu0.1
- 3.6.10-1ubuntu0.3
- 3.6.10-1ubuntu0.4
- 3.6.10-1ubuntu0.5
- 3.6.10-1ubuntu0.5+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
rabbitmq-server Ubuntu:20.04:LTS
- Versions du logiciel
- 3.7.8-4ubuntu2
- 3.7.18-1
- 3.8.2-0ubuntu1
- 3.8.2-0ubuntu1.1
- 3.8.2-0ubuntu1.2
- 3.8.2-0ubuntu1.3
- 3.8.2-0ubuntu1.4
- Plages de versions concernées
- ECOSYSTEM: < 3.8.2-0ubuntu1.5
Mettez à jour vers 3.8.2-0ubuntu1.5
rabbitmq-server Ubuntu:22.04:LTS
- Versions du logiciel
- 3.8.9-3ubuntu1
- 3.9.8-1
- 3.9.8-2
- 3.9.8-3
- 3.9.8-5
- 3.9.8-6
- 3.9.13-1
- 3.9.13-1ubuntu0.22.04.1
- Plages de versions concernées
- ECOSYSTEM: < 3.9.13-1ubuntu0.22.04.2
Mettez à jour vers 3.9.13-1ubuntu0.22.04.2
rabbitmq-server Ubuntu:24.04:LTS
- Versions du logiciel
- 3.12.1-1
- Plages de versions concernées
- ECOSYSTEM: < 3.12.1-1ubuntu1
Mettez à jour vers 3.12.1-1ubuntu1