CVE-2023-46136
CVE-2023-46136 · Werkzeug vulnerable to high resource usage when parsing multipart/form-data containing a large part with CR/LF character at the beginning
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Werkzeug is a comprehensive WSGI web application library. In versions on the 3.x branch prior to 3.0.1 and on the 2.x branch prior to 2.3.8, if an upload of a file that starts with CR or LF and then is followed by megabytes of data without these characters: all of these bytes are appended chunk by chunk into internal bytearray and lookup for boundary is performed on growing buffer. This allows an attacker to cause a denial of service by sending crafted multipart data to an endpoint that will parse it. The amount of CPU time required can block worker processes from handling legitimate requests. This vulnerability has been patched in version 3.0.1 and 2.3.8.
CVSS 8.0 · Élevée · EPSS 1,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
werkzeug
- Versions du logiciel
- >= 3.0.0, < 3.0.1: Concernée
- >= 2.0.0rc1, < 2.3.8: Concernée
Aucun correctif publié
python-werkzeug Debian:12
- Versions du logiciel
- 2.2.2-3
- Plages de versions concernées
- ECOSYSTEM: < 2.2.2-3+deb12u1
Mettez à jour vers 2.2.2-3+deb12u1
python-werkzeug Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 3.0.1-2
Mettez à jour vers 3.0.1-2
python-werkzeug Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 3.0.1-2
Mettez à jour vers 3.0.1-2
werkzeug PyPI
- Versions du logiciel
- 3.0.0
- Plages de versions concernées
- ECOSYSTEM: ≥ 3.0.0, < 3.0.1
Mettez à jour vers 3.0.1
werkzeug PyPI
- Versions du logiciel
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.0a1
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 2.3.7
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.0.0rc1, < 2.3.8
Mettez à jour vers 2.3.8
werkzeug PyPI
- Versions du logiciel
- 0.1
- 0.10
- 0.10.1
- 0.10.2
- 0.10.3
- 0.10.4
- 0.11
- 0.11.1
- 0.11.10
- 0.11.11
- 0.11.12
- 0.11.13
- 0.11.14
- 0.11.15
- 0.11.2
- 0.11.3
- 0.11.4
- 0.11.5
- 0.11.6
- 0.11.7
- 0.11.8
- 0.11.9
- 0.12
- 0.12.1
- 0.12.2
- 0.13
- 0.14
- 0.14.1
- 0.15.0
- 0.15.1
- 0.15.2
- 0.15.3
- 0.15.4
- 0.15.5
- 0.15.6
- 0.16.0
- 0.16.1
- 0.2
- 0.3
- 0.3.1
- 0.4
- 0.4.1
- 0.5
- 0.5.1
- 0.6
- 0.6.1
- 0.6.2
- 0.7
- 0.7.1
- 0.7.2
- 0.8
- 0.8.1
- 0.8.2
- 0.8.3
- 0.9
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 1.0.0
- 1.0.0rc1
- 1.0.1
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.0a1
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 2.3.7
- 3.0.0
- Plages de versions concernées
- {"events": [{"introduced": "0"}, {"fixed": "f3c803b3ade485a45f12b6d6617595350c0f03e2"}, {"fixed": "f2300208d5e2a5076cbbb4c2aad71096fd040ef9"}], "repo": "https://github.com/pallets/werkzeug", "type": "GIT"}
- ECOSYSTEM: < 2.3.8 ∪ ≥ 3.0.0, < 3.0.1
Mettez à jour vers 2.3.8; Mettez à jour vers 3.0.1