CVE-2024-25629
CVE-2024-25629 · c-ares out of bounds read in ares__read_line()
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
c-ares is a C library for asynchronous DNS requests. `ares__read_line()` is used to parse local configuration files such as `/etc/resolv.conf`, `/etc/nsswitch.conf`, the `HOSTALIASES` file, and if using a c-ares version prior to 1.27.0, the `/etc/hosts` file. If any of these configuration files has an embedded `NULL` character as the first character in a new line, it can lead to attempting to read memory prior to the start of the given buffer which may result in a crash. This issue is fixed in c-ares 1.27.0. No known workarounds exist.
CVSS 4.4 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
c-ares
- Versions du logiciel
- < 1.27.0: Concernée
Aucun correctif publié
c-ares Debian:12
- Versions du logiciel
- 1.18.1-3
- 1.19.0-1
- 1.19.1-1
- 1.19.1-2
- 1.19.1-3
- 1.20.0-1
- 1.20.0-2
- 1.20.0-3
- 1.20.1-1
- 1.21.0-1
- 1.22.0-1
- 1.22.1-1
- 1.23.0-1
- 1.24.0-1
- 1.25.0-1
- 1.26.0-1
- 1.26.0-1.1~exp1
- 1.27.0-1
- 1.27.0-1.1
- 1.27.0-1.1~exp1
- 1.27.0-1.2
- 1.28.1-1
- 1.29.0-1
- 1.30.0-1
- 1.31.0-1
- 1.32.2-1
- 1.32.2-2
- 1.32.3-1
- 1.33.0-1
- 1.33.1-1
- 1.33.1-2
- 1.34.2-1
- 1.34.3-1
- 1.34.4-1
- 1.34.4-2
- 1.34.4-2.1
- 1.34.5-1
- 1.34.6-1
- 1.34.7-1
- 1.34.8-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
c-ares Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.27.0-1
Mettez à jour vers 1.27.0-1
c-ares Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.27.0-1
Mettez à jour vers 1.27.0-1
c-ares Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.10.0-2
- 1.10.0-3
- 1.10.0-3ubuntu0.1
- 1.10.0-3ubuntu0.2
- 1.10.0-3ubuntu0.2+esm1
- 1.10.0-3ubuntu0.2+esm2
- Plages de versions concernées
- ECOSYSTEM: < 1.10.0-3ubuntu0.2+esm3
Mettez à jour vers 1.10.0-3ubuntu0.2+esm3
c-ares Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.13.0-2
- 1.13.0-3
- 1.14.0-1
- 1.14.0-1ubuntu0.1
- 1.14.0-1ubuntu0.2
- 1.14.0-1ubuntu0.2+esm1
- Plages de versions concernées
- ECOSYSTEM: < 1.14.0-1ubuntu0.2+esm2
Mettez à jour vers 1.14.0-1ubuntu0.2+esm2
c-ares Ubuntu:20.04:LTS
- Versions du logiciel
- 1.15.0-1build1
- 1.15.0-1ubuntu0.1
- 1.15.0-1ubuntu0.2
- 1.15.0-1ubuntu0.3
- 1.15.0-1ubuntu0.4
- Plages de versions concernées
- ECOSYSTEM: < 1.15.0-1ubuntu0.5
Mettez à jour vers 1.15.0-1ubuntu0.5
c-ares Ubuntu:22.04:LTS
- Versions du logiciel
- 1.17.1-1ubuntu1
- 1.18.1-1
- 1.18.1-1build1
- 1.18.1-1ubuntu0.22.04.1
- 1.18.1-1ubuntu0.22.04.2
- Plages de versions concernées
- ECOSYSTEM: < 1.18.1-1ubuntu0.22.04.3
Mettez à jour vers 1.18.1-1ubuntu0.22.04.3
Sources originales
- https://github.com/c-ares/c-ares/security/advisories/GHSA-mg26-v6qh-x48q
- https://github.com/c-ares/c-ares/commit/a804c04ddc8245fc8adf0e92368709639125e183
- https://lists.fedoraproject.org/archives/list/[email protected]/message/GX37LFPFQ3T6FFMMFYQTEGIQXXN7F27U/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/2P76QYINQNPEHUTEEDOUYIRZ2X6UVZ5K/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/CSCMTSPDIE2UHU34TIXQQHZ6JTE3Y3VF/
- https://nvd.nist.gov/vuln/detail/CVE-2024-25629