p PatchFirst

CVE-2024-26016

CVE-2024-26016 · Apache Superset: Improper authorization validation on dashboards and charts import

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

A low privilege authenticated user could import an existing dashboard or chart that they do not have access to and then modify its metadata, thereby gaining ownership of the object. However, it's important to note that access to the analytical data of these charts and dashboards would still be subject to validation based on data access privileges. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.Users are recommended to upgrade to version 3.1.1, which fixes the issue.

CVSS 4.3 · Moyenne · EPSS 0,9% · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • apache superset

    Versions du logiciel
    • ≥ 0, < 3.0.4: Concernée (semver)
    • ≥ 3.1.0, < 3.1.1: Concernée (semver)

    Mettez à jour vers 3.0.4; Mettez à jour vers 3.1.1

  • apache-superset PyPI

    Versions du logiciel
    • 0.34.0
    • 0.34.1
    • 0.35.1
    • 0.35.2
    • 0.36.0
    • 0.37.0
    • 0.37.1
    • 0.37.2
    • 0.38.0
    • 0.38.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.1.1
    • 2.1.1rc1
    • 2.1.1rc2
    • 2.1.1rc3
    • 2.1.2
    • 2.1.3
    • 3.0.0
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.0.0rc3
    • 3.0.0rc4
    • 3.0.1
    • 3.0.2
    • 3.0.3
    Plages de versions concernées
    • ECOSYSTEM: < 3.0.4

    Mettez à jour vers 3.0.4

  • apache-superset PyPI

    Versions du logiciel
    • 3.1.0
    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.1.0, < 3.1.1

    Mettez à jour vers 3.1.1

  • apache-superset PyPI

    Versions du logiciel
    • 0.34.0
    • 0.34.1
    • 0.35.1
    • 0.35.2
    • 0.36.0
    • 0.37.0
    • 0.37.1
    • 0.37.2
    • 0.38.0
    • 0.38.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.1.1
    • 2.1.1rc1
    • 2.1.1rc2
    • 2.1.1rc3
    • 2.1.2
    • 2.1.3
    • 3.0.0
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.0.0rc3
    • 3.0.0rc4
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.1.0
    Plages de versions concernées
    • ECOSYSTEM: < 3.0.4 ∪ ≥ 3.1.0, < 3.1.1

    Mettez à jour vers 3.0.4; Mettez à jour vers 3.1.1

Sources originales

Vérifiez votre serveur →