CVE-2024-28233
CVE-2024-28233 · XSS in JupyterHub via Self-XSS leveraged by Cookie Tossing
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
JupyterHub is an open source multi-user server for Jupyter notebooks. By tricking a user into visiting a malicious subdomain, the attacker can achieve an XSS directly affecting the former's session. More precisely, in the context of JupyterHub, this XSS could achieve full access to JupyterHub API and user's single-user server. The affected configurations are single-origin JupyterHub deployments and JupyterHub deployments with user-controlled applications running on subdomains or peer subdomains of either the Hub or a single-user server. This vulnerability is fixed in 4.1.0.
CVSS 8.1 · Élevée · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
jupyterhub
- Versions du logiciel
- < 4.1.0: Concernée
Aucun correctif publié
jupyterhub Debian:12
- Versions du logiciel
- 3.0.0+ds1-1
- 5.0.0+ds1-1
- 5.0.0+ds1-2
- 5.0.0+ds1-3
- 5.0.0+ds1-4
- 5.2.1+ds1-1
- 5.2.1+ds1-2
- 5.2.1+ds1-3
- 5.2.1+ds1-4
- 5.2.1+ds1-5
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyterhub Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 5.0.0+ds1-1
Mettez à jour vers 5.0.0+ds1-1
jupyterhub Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 5.0.0+ds1-1
Mettez à jour vers 5.0.0+ds1-1
jupyterhub PyPI
- Versions du logiciel
- 0.1.0
- 0.2.0
- 0.3.0
- 0.4.0
- 0.4.1
- 0.5.0
- 0.6.0
- 0.6.1
- 0.7.0
- 0.7.0b1
- 0.7.1
- 0.7.2
- 0.8.0
- 0.8.0b1
- 0.8.0b2
- 0.8.0b3
- 0.8.0b4
- 0.8.0b5
- 0.8.0rc1
- 0.8.0rc2
- 0.8.1
- 0.9.0
- 0.9.0b1
- 0.9.0b2
- 0.9.0b3
- 0.9.0rc1
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 1.0.0
- 1.0.0b1
- 1.0.0b2
- 1.1.0
- 1.1.0b1
- 1.2.0
- 1.2.0b1
- 1.2.1
- 1.2.2
- 1.3.0
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 2.0.0
- 2.0.0b1
- 2.0.0b2
- 2.0.0b3
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.1
- 2.0.2
- 2.1.0
- 2.1.1
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 3.0.0
- 3.0.0b1
- 3.1.0
- 3.1.1
- 4.0.0
- 4.0.0b1
- 4.0.0b2
- 4.0.1
- 4.0.2
- Plages de versions concernées
- ECOSYSTEM: < 4.1.0
Mettez à jour vers 4.1.0
jupyterhub Ubuntu:22.04:LTS
- Versions du logiciel
- 2.0.0+ds1-1
- 2.0.0+ds1-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyterhub Ubuntu:24.04:LTS
- Versions du logiciel
- 3.0.0+ds1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyterhub Ubuntu:25.10
- Versions du logiciel
- 5.2.1+ds1-2
- 5.2.1+ds1-3
- 5.2.1+ds1-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyterhub Ubuntu:26.10
- Versions du logiciel
- 5.2.1+ds1-4
- 5.2.1+ds1-5
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
jupyterhub Ubuntu:26.04:LTS
- Versions du logiciel
- 5.2.1+ds1-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié