p PatchFirst

CVE-2024-28246

CVE-2024-28246 · KaTeX is missing normalization of the protocol in URLs allows bypassing forbidden protocols

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

KaTeX is a JavaScript library for TeX math rendering on the web. Code that uses KaTeX's `trust` option, specifically that provides a function to blacklist certain URL protocols, can be fooled by URLs in malicious inputs that use uppercase characters in the protocol. In particular, this can allow for malicious input to generate `javascript:` links in the output, even if the `trust` function tries to forbid this protocol via `trust: (context) => context.protocol !== 'javascript'`. Upgrade to KaTeX v0.16.10 to remove this vulnerability.

CVSS 5.5 · Moyenne · EPSS 0,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • katex

    Versions du logiciel
    • >= 0.11.0, < 0.16.10: Concernée

    Aucun correctif publié

  • node-katex Debian:12

    Versions du logiciel
    • 0.16.10+~cs6.1.0-1
    • 0.16.10+~cs6.1.0-2
    • 0.16.10+~cs6.1.0-3
    • 0.16.10+~cs6.1.0-4
    • 0.16.10+~cs6.1.0-5
    • 0.16.10+~cs6.1.0-6
    • 0.16.10+~cs6.1.0-7
    • 0.16.10+~cs6.1.0-8
    • 0.16.10+~cs6.1.0-9
    • 0.16.4+~cs6.1.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-katex Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 0.16.10+~cs6.1.0-1

    Mettez à jour vers 0.16.10+~cs6.1.0-1

  • node-katex Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 0.16.10+~cs6.1.0-1

    Mettez à jour vers 0.16.10+~cs6.1.0-1

  • katex npm

    Plages de versions concernées
    • SEMVER: ≥ 0.11.0, < 0.16.10

    Mettez à jour vers 0.16.10

  • node-katex Ubuntu:Pro:22.04:LTS

    Versions du logiciel
    • 0.10.2+dfsg-8
    • 0.10.2+dfsg-9
    • 0.10.2+dfsg-10
    • 0.13.11+~cs6.0.0-2
    Plages de versions concernées
    • ECOSYSTEM: < 0.13.11+~cs6.0.0-2ubuntu0.1~esm1

    Mettez à jour vers 0.13.11+~cs6.0.0-2ubuntu0.1~esm1

Sources originales

Vérifiez votre serveur →