CVE-2024-30261
CVE-2024-30261 · Undici's fetch with integrity option is too lax when algorithm is specified but hash value is in incorrect
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Undici is an HTTP/1.1 client, written from scratch for Node.js. An attacker can alter the `integrity` option passed to `fetch()`, allowing `fetch()` to accept requests as valid even if they have been tampered. This vulnerability was patched in version(s) 5.28.4 and 6.11.1.
CVSS 2.6 · Faible · EPSS 0,8% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
undici
- Versions du logiciel
- >= 6.0.0, < 6.11.1: Concernée
- < 5.28.4: Concernée
Aucun correctif publié
node-undici Debian:12
- Versions du logiciel
- 5.15.0+dfsg1+~cs20.10.9.3-1
- 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u1
- 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u2
- 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3
- 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4
- 5.19.1+dfsg1+~cs20.10.9.5-1
- 5.19.1+dfsg1+~cs20.10.9.5-2
- 5.22.1+dfsg1+~cs20.10.10.2-1
- 5.26.3+dfsg1+~cs23.10.12-1
- 5.26.3+dfsg1+~cs23.10.12-2
- 5.26.3+dfsg1+~cs23.10.12-3
- 5.28.0+dfsg1+~cs23.11.12.3-1
- 5.28.0+dfsg1+~cs23.11.12.3-2
- 5.28.2+dfsg1+~cs23.11.12.3-1
- 5.28.2+dfsg1+~cs23.11.12.3-2
- 5.28.2+dfsg1+~cs23.11.12.3-3
- 5.28.2+dfsg1+~cs23.11.12.3-4
- 5.28.2+dfsg1+~cs23.11.12.3-5
- 5.28.2+dfsg1+~cs23.11.12.3-6
- 5.28.4+dfsg1+~cs23.12.11-1
- 5.28.4+dfsg1+~cs23.12.11-2
- 7.1.0+dfsg1+~cs24.12.10-1
- 7.15.0+dfsg+~cs3.2.0-1
- 7.15.0+dfsg+~cs3.2.0-3
- 7.16.0+dfsg+~cs3.2.0-1
- 7.16.0+dfsg+~cs3.2.0-2
- 7.18.2+dfsg+~cs3.2.0-1
- 7.2.3+dfsg1+~cs24.12.11-1
- 7.2.3+dfsg1+~cs24.12.11-2
- 7.24.5+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-1
- 7.24.6+dfsg+~cs3.2.0-2
- 7.24.6+dfsg+~cs3.2.0-3
- 7.3.0+dfsg1+~cs24.12.11-1
- 7.3.0+dfsg1+~cs24.12.11-2
- 8.10.2+dfsg+~cs3.2.2-1
- 8.5.0+dfsg+~cs3.2.0-1
- 8.5.0+dfsg+~cs3.2.0-2
- 8.5.0+dfsg+~cs3.2.0-3
- 8.9.0+dfsg+~cs3.2.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-undici Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 5.28.4+dfsg1+~cs23.12.11-1
Mettez à jour vers 5.28.4+dfsg1+~cs23.12.11-1
node-undici Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 5.28.4+dfsg1+~cs23.12.11-1
Mettez à jour vers 5.28.4+dfsg1+~cs23.12.11-1
undici npm
- Plages de versions concernées
- SEMVER: < 5.28.4
Mettez à jour vers 5.28.4
undici npm
- Plages de versions concernées
- SEMVER: ≥ 6.0.0, < 6.11.1
Mettez à jour vers 6.11.1
node-undici Ubuntu:24.04:LTS
- Versions du logiciel
- 5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1
- 5.26.3+dfsg1+~cs23.10.12-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/nodejs/undici/security/advisories/GHSA-9qxr-qj54-h672
- https://github.com/nodejs/undici/commit/2b39440bd9ded841c93dd72138f3b1763ae26055
- https://github.com/nodejs/undici/commit/d542b8cd39ec1ba303f038ea26098c3f355974f3
- https://hackerone.com/reports/2377760
- https://lists.fedoraproject.org/archives/list/[email protected]/message/P6Q4RGETHVYVHDIQGTJGU5AV6NJEI67E/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/HQVHWAS6WDXXIU7F72XI55VZ2LTZUB33/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/NC3V3HFZ5MOJRZDY5ZELL6REIRSPFROJ/
- https://security.netapp.com/advisory/ntap-20240905-0008/
- https://nvd.nist.gov/vuln/detail/CVE-2024-30261