CVE-2024-32465
CVE-2024-32465 · Git's protections for cloning untrusted repositories can be bypassed
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Git is a revision control system. The Git project recommends to avoid working in untrusted repositories, and instead to clone it first with `git clone --no-local` to obtain a clean copy. Git has specific protections to make that a safe operation even with an untrusted source repository, but vulnerabilities allow those protections to be bypassed. In the context of cloning local repositories owned by other users, this vulnerability has been covered in CVE-2024-32004. But there are circumstances where the fixes for CVE-2024-32004 are not enough: For example, when obtaining a `.zip` file containing a full copy of a Git repository, it should not be trusted by default to be safe, as e.g. hooks could be configured to run within the context of that repository. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid using Git in repositories that have been obtained via archives from untrusted sources.
CVSS 7.4 · Élevée · EPSS 1,0% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
git
- Versions du logiciel
- = 2.45.0: Concernée
- = 2.44.0: Concernée
- >= 2.43.0, < 2.43.4: Concernée
- >= 2.42.0, < 2.42.2: Concernée
- = 2.41.0: Concernée
- >= 2.40.0, < 2.40.2: Concernée
- < 2.39.4: Concernée
Aucun correctif publié
git Debian:12
- Versions du logiciel
- 1:2.39.2+next.20230215-1
- 1:2.39.2-1.1
- Plages de versions concernées
- ECOSYSTEM: < 1:2.39.5-0+deb12u1
Mettez à jour vers 1:2.39.5-0+deb12u1
git Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1:2.45.1-1
Mettez à jour vers 1:2.45.1-1
git Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1:2.45.1-1
Mettez à jour vers 1:2.45.1-1
git Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1:2.14.1-1ubuntu4
- 1:2.15.1-1ubuntu2
- 1:2.17.0-1ubuntu1
- 1:2.17.1-1ubuntu0.1
- 1:2.17.1-1ubuntu0.3
- 1:2.17.1-1ubuntu0.4
- 1:2.17.1-1ubuntu0.5
- 1:2.17.1-1ubuntu0.6
- 1:2.17.1-1ubuntu0.7
- 1:2.17.1-1ubuntu0.8
- 1:2.17.1-1ubuntu0.9
- 1:2.17.1-1ubuntu0.10
- 1:2.17.1-1ubuntu0.11
- 1:2.17.1-1ubuntu0.12
- 1:2.17.1-1ubuntu0.13
- 1:2.17.1-1ubuntu0.14
- 1:2.17.1-1ubuntu0.15
- 1:2.17.1-1ubuntu0.16
- 1:2.17.1-1ubuntu0.17
- 1:2.17.1-1ubuntu0.18
- Plages de versions concernées
- ECOSYSTEM: < 1:2.17.1-1ubuntu0.18+esm1
Mettez à jour vers 1:2.17.1-1ubuntu0.18+esm1
git Ubuntu:20.04:LTS
- Versions du logiciel
- 1:2.20.1-2ubuntu1
- 1:2.24.0-1ubuntu1
- 1:2.24.0-1ubuntu2
- 1:2.25.0-1ubuntu1
- 1:2.25.1-1ubuntu1
- 1:2.25.1-1ubuntu2
- 1:2.25.1-1ubuntu3
- 1:2.25.1-1ubuntu3.1
- 1:2.25.1-1ubuntu3.2
- 1:2.25.1-1ubuntu3.3
- 1:2.25.1-1ubuntu3.4
- 1:2.25.1-1ubuntu3.5
- 1:2.25.1-1ubuntu3.6
- 1:2.25.1-1ubuntu3.7
- 1:2.25.1-1ubuntu3.8
- 1:2.25.1-1ubuntu3.10
- 1:2.25.1-1ubuntu3.11
- Plages de versions concernées
- ECOSYSTEM: < 1:2.25.1-1ubuntu3.12
Mettez à jour vers 1:2.25.1-1ubuntu3.12
git Ubuntu:22.04:LTS
- Versions du logiciel
- 1:2.32.0-1ubuntu1
- 1:2.33.1-1ubuntu1
- 1:2.34.1-1ubuntu1
- 1:2.34.1-1ubuntu1.1
- 1:2.34.1-1ubuntu1.2
- 1:2.34.1-1ubuntu1.4
- 1:2.34.1-1ubuntu1.5
- 1:2.34.1-1ubuntu1.6
- 1:2.34.1-1ubuntu1.8
- 1:2.34.1-1ubuntu1.9
- 1:2.34.1-1ubuntu1.10
- Plages de versions concernées
- ECOSYSTEM: < 1:2.34.1-1ubuntu1.11
Mettez à jour vers 1:2.34.1-1ubuntu1.11
git Ubuntu:24.04:LTS
- Versions du logiciel
- 1:2.40.1-1ubuntu1
- 1:2.43.0-1ubuntu1
- 1:2.43.0-1ubuntu5
- 1:2.43.0-1ubuntu6
- 1:2.43.0-1ubuntu7
- Plages de versions concernées
- ECOSYSTEM: < 1:2.43.0-1ubuntu7.1
Mettez à jour vers 1:2.43.0-1ubuntu7.1
Sources originales
- https://github.com/git/git/security/advisories/GHSA-vm9j-46j9-qvq4
- https://github.com/git/git/commit/7b70e9efb18c2cc3f219af399bd384c5801ba1d7
- https://git-scm.com/docs/git#_security
- https://git-scm.com/docs/git-clone
- https://lists.fedoraproject.org/archives/list/[email protected]/message/S4CK4IYTXEOBZTEM5K3T6LWOIZ3S44AR/
- http://www.openwall.com/lists/oss-security/2024/05/14/2
- https://lists.debian.org/debian-lts-announce/2024/06/msg00018.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00009.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-32465