CVE-2024-32982
CVE-2024-32982 · Litestar and Starlite affected by Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Litestar and Starlite is an Asynchronous Server Gateway Interface (ASGI) framework. Prior to 2.8.3, 2.7.2, and 2.6.4, a Local File Inclusion (LFI) vulnerability has been discovered in the static file serving component of LiteStar. This vulnerability allows attackers to exploit path traversal flaws, enabling unauthorized access to sensitive files outside the designated directories. Such access can lead to the disclosure of sensitive information or potentially compromise the server. The vulnerability is located in the file path handling mechanism within the static content serving function, specifically at `litestar/static_files/base.py`. This vulnerability is fixed in versions 2.8.3, 2.7.2, and 2.6.4.
CVSS 8.2 · Élevée · EPSS 0,7% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
litestar
- Versions du logiciel
- >= 2.8.0, < 2.8.3: Concernée
- >= 1.37.0, <= 1.51.14: Concernée
- >= 2.7.0, < 2.7.2: Concernée
- >= 2.0.0, < 2.6.4: Concernée
Aucun correctif publié
litestar PyPI
- Versions du logiciel
- 2.8.0
- 2.8.1
- 2.8.2
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.8.0, < 2.8.3
Mettez à jour vers 2.8.3
starlite PyPI
- Versions du logiciel
- 1.37.0
- 1.38.0
- 1.39.0
- 1.40.0
- 1.40.1
- 1.41.0
- 1.42.0
- 1.43.0
- 1.43.1
- 1.44.0
- 1.45.0
- 1.45.1
- 1.46.0
- 1.47.0
- 1.48.0
- 1.48.1
- 1.49.0
- 1.50.0
- 1.50.1
- 1.50.2
- 1.51.0
- 1.51.1
- 1.51.10
- 1.51.11
- 1.51.12
- 1.51.13
- 1.51.14
- 1.51.15
- 1.51.2
- 1.51.3
- 1.51.4
- 1.51.5
- 1.51.6
- 1.51.7
- 1.51.8
- 1.51.9
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.37.0, < 1.51.16
Mettez à jour vers 1.51.16
litestar PyPI
- Versions du logiciel
- 2.7.0
- 2.7.1
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.7.0, < 2.7.2
Mettez à jour vers 2.7.2
litestar PyPI
- Versions du logiciel
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.2.0
- 2.2.1
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.0.0, < 2.6.4
Mettez à jour vers 2.6.4
litestar PyPI
- Versions du logiciel
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.2.0
- 2.2.1
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.8.2
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.0.0, < 2.6.4 ∪ ≥ 2.7.0, < 2.7.2 ∪ ≥ 2.8.0, < 2.8.3
Mettez à jour vers 2.6.4; Mettez à jour vers 2.7.2; Mettez à jour vers 2.8.3