p PatchFirst

CVE-2024-38476

CVE-2024-38476 · Apache HTTP Server may use exploitable/malicious backend application output to run local handlers via internal redirect

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Vulnerability in core of Apache HTTP Server 2.4.59 and earlier are vulnerably to information disclosure, SSRF or local script execution via backend applications whose response headers are malicious or exploitable. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

CVSS 9.8 · Critique · EPSS 41,6% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · web

Produits et versions concernés

  • apache httpd

    Versions du logiciel
    • ≥ 2.4.0, ≤ 2.4.59: Concernée (semver)

    Aucun correctif publié

  • apache2 Debian:12

    Versions du logiciel
    • 2.4.57-2
    • 2.4.57-3
    • 2.4.58-1
    • 2.4.59-1
    • 2.4.59-1~deb10u1
    • 2.4.59-1~deb11u1
    • 2.4.59-1~deb12u1
    • 2.4.59-2
    • 2.4.60-1
    • 2.4.61-1~deb11u1
    Plages de versions concernées
    • ECOSYSTEM: < 2.4.61-1~deb12u1

    Mettez à jour vers 2.4.61-1~deb12u1

  • apache2 Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.60-1

    Mettez à jour vers 2.4.60-1

  • apache2 Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 2.4.60-1

    Mettez à jour vers 2.4.60-1

  • apache2 Ubuntu:Pro:14.04:LTS

    Versions du logiciel
    • 2.4.6-2ubuntu2
    • 2.4.6-2ubuntu3
    • 2.4.6-2ubuntu4
    • 2.4.7-1ubuntu1
    • 2.4.7-1ubuntu2
    • 2.4.7-1ubuntu3
    • 2.4.7-1ubuntu4
    • 2.4.7-1ubuntu4.1
    • 2.4.7-1ubuntu4.4
    • 2.4.7-1ubuntu4.5
    • 2.4.7-1ubuntu4.6
    • 2.4.7-1ubuntu4.7
    • 2.4.7-1ubuntu4.8
    • 2.4.7-1ubuntu4.9
    • 2.4.7-1ubuntu4.10
    • 2.4.7-1ubuntu4.11
    • 2.4.7-1ubuntu4.13
    • 2.4.7-1ubuntu4.15
    • 2.4.7-1ubuntu4.16
    • 2.4.7-1ubuntu4.17
    • 2.4.7-1ubuntu4.18
    • 2.4.7-1ubuntu4.19
    • 2.4.7-1ubuntu4.20
    • 2.4.7-1ubuntu4.21
    • 2.4.7-1ubuntu4.22
    • 2.4.7-1ubuntu4.22+esm1
    • 2.4.7-1ubuntu4.22+esm2
    • 2.4.7-1ubuntu4.22+esm3
    • 2.4.7-1ubuntu4.22+esm4
    • 2.4.7-1ubuntu4.22+esm5
    • 2.4.7-1ubuntu4.22+esm6
    • 2.4.7-1ubuntu4.22+esm8
    • 2.4.7-1ubuntu4.22+esm9
    • 2.4.7-1ubuntu4.22+esm10
    Plages de versions concernées
    • ECOSYSTEM: < 2.4.7-1ubuntu4.22+esm12

    Mettez à jour vers 2.4.7-1ubuntu4.22+esm12

  • apache2 Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 2.4.12-2ubuntu2
    • 2.4.17-1ubuntu1
    • 2.4.17-2ubuntu1
    • 2.4.17-3ubuntu1
    • 2.4.18-1ubuntu1
    • 2.4.18-2ubuntu1
    • 2.4.18-2ubuntu2
    • 2.4.18-2ubuntu3
    • 2.4.18-2ubuntu3.1
    • 2.4.18-2ubuntu3.2
    • 2.4.18-2ubuntu3.3
    • 2.4.18-2ubuntu3.4
    • 2.4.18-2ubuntu3.5
    • 2.4.18-2ubuntu3.7
    • 2.4.18-2ubuntu3.8
    • 2.4.18-2ubuntu3.9
    • 2.4.18-2ubuntu3.10
    • 2.4.18-2ubuntu3.12
    • 2.4.18-2ubuntu3.13
    • 2.4.18-2ubuntu3.14
    • 2.4.18-2ubuntu3.15
    • 2.4.18-2ubuntu3.17
    • 2.4.18-2ubuntu3.17+esm1
    • 2.4.18-2ubuntu3.17+esm2
    • 2.4.18-2ubuntu3.17+esm3
    • 2.4.18-2ubuntu3.17+esm4
    • 2.4.18-2ubuntu3.17+esm5
    • 2.4.18-2ubuntu3.17+esm6
    • 2.4.18-2ubuntu3.17+esm7
    • 2.4.18-2ubuntu3.17+esm8
    • 2.4.18-2ubuntu3.17+esm9
    • 2.4.18-2ubuntu3.17+esm10
    • 2.4.18-2ubuntu3.17+esm11
    • 2.4.18-2ubuntu3.17+esm12
    Plages de versions concernées
    • ECOSYSTEM: < 2.4.18-2ubuntu3.17+esm13

    Mettez à jour vers 2.4.18-2ubuntu3.17+esm13

  • apache2 Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 2.4.27-2ubuntu3
    • 2.4.29-1ubuntu1
    • 2.4.29-1ubuntu2
    • 2.4.29-1ubuntu3
    • 2.4.29-1ubuntu4
    • 2.4.29-1ubuntu4.1
    • 2.4.29-1ubuntu4.2
    • 2.4.29-1ubuntu4.3
    • 2.4.29-1ubuntu4.4
    • 2.4.29-1ubuntu4.5
    • 2.4.29-1ubuntu4.6
    • 2.4.29-1ubuntu4.7
    • 2.4.29-1ubuntu4.8
    • 2.4.29-1ubuntu4.10
    • 2.4.29-1ubuntu4.11
    • 2.4.29-1ubuntu4.12
    • 2.4.29-1ubuntu4.13
    • 2.4.29-1ubuntu4.14
    • 2.4.29-1ubuntu4.16
    • 2.4.29-1ubuntu4.17
    • 2.4.29-1ubuntu4.18
    • 2.4.29-1ubuntu4.19
    • 2.4.29-1ubuntu4.20
    • 2.4.29-1ubuntu4.21
    • 2.4.29-1ubuntu4.22
    • 2.4.29-1ubuntu4.23
    • 2.4.29-1ubuntu4.24
    • 2.4.29-1ubuntu4.25
    • 2.4.29-1ubuntu4.26
    • 2.4.29-1ubuntu4.27
    • 2.4.29-1ubuntu4.27+esm1
    • 2.4.29-1ubuntu4.27+esm2
    Plages de versions concernées
    • ECOSYSTEM: < 2.4.29-1ubuntu4.27+esm3

    Mettez à jour vers 2.4.29-1ubuntu4.27+esm3

  • apache2 Ubuntu:20.04:LTS

    Versions du logiciel
    • 2.4.41-1ubuntu1
    • 2.4.41-4ubuntu1
    • 2.4.41-4ubuntu2
    • 2.4.41-4ubuntu3
    • 2.4.41-4ubuntu3.1
    • 2.4.41-4ubuntu3.3
    • 2.4.41-4ubuntu3.4
    • 2.4.41-4ubuntu3.5
    • 2.4.41-4ubuntu3.6
    • 2.4.41-4ubuntu3.7
    • 2.4.41-4ubuntu3.8
    • 2.4.41-4ubuntu3.9
    • 2.4.41-4ubuntu3.10
    • 2.4.41-4ubuntu3.11
    • 2.4.41-4ubuntu3.12
    • 2.4.41-4ubuntu3.13
    • 2.4.41-4ubuntu3.14
    • 2.4.41-4ubuntu3.15
    • 2.4.41-4ubuntu3.16
    • 2.4.41-4ubuntu3.17
    Plages de versions concernées
    • ECOSYSTEM: < 2.4.41-4ubuntu3.19

    Mettez à jour vers 2.4.41-4ubuntu3.19

  • apache2 Ubuntu:22.04:LTS

    Versions du logiciel
    • 2.4.48-3.1ubuntu3
    • 2.4.48-3.1ubuntu4
    • 2.4.51-2ubuntu1
    • 2.4.52-1ubuntu1
    • 2.4.52-1ubuntu2
    • 2.4.52-1ubuntu4
    • 2.4.52-1ubuntu4.1
    • 2.4.52-1ubuntu4.2
    • 2.4.52-1ubuntu4.3
    • 2.4.52-1ubuntu4.4
    • 2.4.52-1ubuntu4.5
    • 2.4.52-1ubuntu4.6
    • 2.4.52-1ubuntu4.7
    • 2.4.52-1ubuntu4.8
    • 2.4.52-1ubuntu4.9
    Plages de versions concernées
    • ECOSYSTEM: < 2.4.52-1ubuntu4.10

    Mettez à jour vers 2.4.52-1ubuntu4.10

  • apache2 Ubuntu:24.04:LTS

    Versions du logiciel
    • 2.4.57-2ubuntu2
    • 2.4.57-2ubuntu3
    • 2.4.58-1ubuntu1
    • 2.4.58-1ubuntu2
    • 2.4.58-1ubuntu6
    • 2.4.58-1ubuntu7
    • 2.4.58-1ubuntu8
    • 2.4.58-1ubuntu8.1
    Plages de versions concernées
    • ECOSYSTEM: < 2.4.58-1ubuntu8.2

    Mettez à jour vers 2.4.58-1ubuntu8.2

Sources originales

Vérifiez votre serveur →