CVE-2024-39877
CVE-2024-39877 · Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
CVSS 8.8 · Élevée · EPSS 1,7% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
apache airflow
- Versions du logiciel
- ≥ 2.4.0, < 2.9.3: Concernée (semver)
Mettez à jour vers 2.9.3
apache-airflow PyPI
- Versions du logiciel
- 2.4.0
- 2.4.1
- 2.4.1rc1
- 2.4.2
- 2.4.2rc1
- 2.4.3
- 2.4.3rc1
- 2.5.0
- 2.5.0rc1
- 2.5.0rc2
- 2.5.0rc3
- 2.5.1
- 2.5.1rc1
- 2.5.1rc2
- 2.5.2
- 2.5.2rc1
- 2.5.2rc2
- 2.5.3
- 2.5.3rc1
- 2.5.3rc2
- 2.6.0
- 2.6.0b1
- 2.6.0rc1
- 2.6.0rc2
- 2.6.0rc3
- 2.6.0rc4
- 2.6.0rc5
- 2.6.1
- 2.6.1rc1
- 2.6.1rc2
- 2.6.1rc3
- 2.6.2
- 2.6.2rc1
- 2.6.2rc2
- 2.6.3
- 2.6.3rc1
- 2.7.0
- 2.7.0b1
- 2.7.0rc1
- 2.7.0rc2
- 2.7.1
- 2.7.1rc1
- 2.7.1rc2
- 2.7.2
- 2.7.2rc1
- 2.7.3
- 2.7.3rc1
- 2.8.0
- 2.8.0b1
- 2.8.0rc1
- 2.8.0rc2
- 2.8.0rc3
- 2.8.0rc4
- 2.8.1
- 2.8.1rc1
- 2.8.2
- 2.8.2rc1
- 2.8.2rc2
- 2.8.2rc3
- 2.8.3
- 2.8.3rc1
- 2.8.4
- 2.8.4rc1
- 2.9.0
- 2.9.0b1
- 2.9.0b2
- 2.9.0rc1
- 2.9.0rc2
- 2.9.0rc3
- 2.9.1
- 2.9.1rc1
- 2.9.1rc2
- 2.9.2
- 2.9.2rc1
- 2.9.3rc1
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.4.0, < 2.9.3
Mettez à jour vers 2.9.3