CVE-2024-41811
CVE-2024-41811 · ipl/web susceptible to Cross-Site Request Forgery (CSRF)
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
ipl/web is a set of common web components for php projects. Some of the recent development by Icinga is, under certain circumstances, susceptible to cross site request forgery. (CSRF). All affected products, in any version, will be unaffected by this once `icinga-php-library` is upgraded. Version 0.10.1 includes a fix for this. It will be published as part of the `icinga-php-library` v0.14.1 release.
CVSS 3.9 · Faible · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Produits et versions concernés
ipl-web
- Versions du logiciel
- < 0.10.1: Concernée
Aucun correctif publié
icinga-php-library Debian:12
- Versions du logiciel
- 0.10.1-1
- 0.11.0-1~exp1
- 0.11.0-1~exp2
- 0.11.1-1~exp1
- 0.12.0-1
- 0.12.0-1~exp1
- 0.13.0-1
- 0.13.0-1~exp1
- 0.13.1-1
- 0.13.2-1
- 0.14.0-1
- 0.14.1-1
- 0.14.2-1
- 0.16.0-1~exp1
- 0.16.1-1~exp1
- 0.17.0-1
- 0.17.0-1~exp1
- 0.17.1-1
- 0.18.0-1
- 0.18.1-1
- 0.19.0-1
- 0.19.1-1
- 0.19.2-1
- 1.0.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
icinga-php-library Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 0.14.1-1
Mettez à jour vers 0.14.1-1
icinga-php-library Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 0.14.1-1
Mettez à jour vers 0.14.1-1
ipl/web Packagist
- Versions du logiciel
- v0.1.0
- v0.10.0
- v0.2.0
- v0.2.1
- v0.3.0
- v0.4.0
- v0.5.0
- v0.6.0
- v0.7.0
- v0.7.1
- v0.8.0
- v0.9.0
- v0.9.1
- v0.9.2
- Plages de versions concernées
- ECOSYSTEM: < 0.10.1
Mettez à jour vers 0.10.1
icinga-php-library Ubuntu:22.04:LTS
- Versions du logiciel
- 0.6.1-1
- 0.7.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
icinga-php-library Ubuntu:24.04:LTS
- Versions du logiciel
- 0.10.1-1
- 0.13.0-1
- 0.13.1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié