p PatchFirst

CVE-2024-4603

CVE-2024-4603 · Excessive time spent checking DSA keys and parameters

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Issue summary: Checking excessively long DSA keys or parameters may be very slow. Impact summary: Applications that use the functions EVP_PKEY_param_check() or EVP_PKEY_public_check() to check a DSA public key or DSA parameters may experience long delays. Where the key or parameters that are being checked have been obtained from an untrusted source this may lead to a Denial of Service. The functions EVP_PKEY_param_check() or EVP_PKEY_public_check() perform various checks on DSA parameters. Some of those computations take a long time if the modulus (`p` parameter) is too large. Trying to use a very large modulus is slow and OpenSSL will not allow using public keys with a modulus which is over 10,000 bits in length for signature verification. However the key and parameter check functions do not limit the modulus size when performing the checks. An application that calls EVP_PKEY_param_check() or EVP_PKEY_public_check() and supplies a key or parameters obtained from an untrusted source could be vulnerable to a Denial of Service attack. These functions are not called by OpenSSL itself on untrusted DSA keys so only applications that directly call these functions may be vulnerable. Also vulnerable are the OpenSSL pkey and pkeyparam command line applications when using the `-check` option. The OpenSSL SSL/TLS implementation is not affected by this issue. The OpenSSL 3.0 and 3.1 FIPS providers are affected by this issue.

CVSS 5.3 · Moyenne · EPSS 1,1% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · network

Produits et versions concernés

  • openssl

    Versions du logiciel
    • ≥ 3.0.0, < 3.0.14: Concernée (semver)
    • ≥ 3.1.0, < 3.1.6: Concernée (semver)
    • ≥ 3.2.0, < 3.2.2: Concernée (semver)
    • ≥ 3.3.0, < 3.3.1: Concernée (semver)

    Mettez à jour vers 3.0.14; Mettez à jour vers 3.1.6; Mettez à jour vers 3.2.2; Mettez à jour vers 3.3.1

  • openssl Debian:12

    Versions du logiciel
    • 3.0.10-1
    • 3.0.10-1~deb12u1
    • 3.0.11-1
    • 3.0.11-1~deb12u1
    • 3.0.11-1~deb12u2
    • 3.0.12-1
    • 3.0.12-2
    • 3.0.13-1~deb12u1
    • 3.0.13-1~deb12u2
    • 3.0.9-1
    Plages de versions concernées
    • ECOSYSTEM: < 3.0.14-1~deb12u1

    Mettez à jour vers 3.0.14-1~deb12u1

  • openssl Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 3.2.2-1

    Mettez à jour vers 3.2.2-1

  • openssl Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 3.2.2-1

    Mettez à jour vers 3.2.2-1

  • nodejs Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 0.10.25~dfsg2-2ubuntu1
    • 4.2.2~dfsg-1
    • 4.2.3~dfsg-1
    • 4.2.4~dfsg-1ubuntu1
    • 4.2.4~dfsg-2
    • 4.2.6~dfsg-1ubuntu1
    • 4.2.6~dfsg-1ubuntu4
    • 4.2.6~dfsg-1ubuntu4.1
    • 4.2.6~dfsg-1ubuntu4.2
    • 4.2.6~dfsg-1ubuntu4.2+esm1
    • 4.2.6~dfsg-1ubuntu4.2+esm2
    • 4.2.6~dfsg-1ubuntu4.2+esm3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • nodejs Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 6.11.4~dfsg-1ubuntu1
    • 6.11.4~dfsg-1ubuntu2
    • 6.12.0~dfsg-1ubuntu1
    • 6.12.0~dfsg-2ubuntu1
    • 6.12.0~dfsg-2ubuntu2
    • 8.10.0~dfsg-2
    • 8.10.0~dfsg-2ubuntu0.2
    • 8.10.0~dfsg-2ubuntu0.3
    • 8.10.0~dfsg-2ubuntu0.4
    • 8.10.0~dfsg-2ubuntu0.4+esm1
    • 8.10.0~dfsg-2ubuntu0.4+esm2
    • 8.10.0~dfsg-2ubuntu0.4+esm3
    • 8.10.0~dfsg-2ubuntu0.4+esm4
    • 8.10.0~dfsg-2ubuntu0.4+esm5
    • 8.10.0~dfsg-2ubuntu0.4+esm6
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • openssl Ubuntu:22.04:LTS

    Versions du logiciel
    • 1.1.1l-1ubuntu1
    • 3.0.0-1ubuntu1
    • 3.0.1-0ubuntu1
    • 3.0.2-0ubuntu1
    • 3.0.2-0ubuntu1.1
    • 3.0.2-0ubuntu1.2
    • 3.0.2-0ubuntu1.4
    • 3.0.2-0ubuntu1.5
    • 3.0.2-0ubuntu1.6
    • 3.0.2-0ubuntu1.7
    • 3.0.2-0ubuntu1.8
    • 3.0.2-0ubuntu1.9
    • 3.0.2-0ubuntu1.10
    • 3.0.2-0ubuntu1.12
    • 3.0.2-0ubuntu1.13
    • 3.0.2-0ubuntu1.14
    • 3.0.2-0ubuntu1.15
    • 3.0.2-0ubuntu1.16
    Plages de versions concernées
    • ECOSYSTEM: < 3.0.2-0ubuntu1.17

    Mettez à jour vers 3.0.2-0ubuntu1.17

  • nodejs Ubuntu:Pro:22.04:LTS

    Versions du logiciel
    • 12.22.5~dfsg-5ubuntu1
    • 12.22.7~dfsg-2ubuntu1
    • 12.22.7~dfsg-2ubuntu3
    • 12.22.9~dfsg-1ubuntu2
    • 12.22.9~dfsg-1ubuntu3
    • 12.22.9~dfsg-1ubuntu3.1
    • 12.22.9~dfsg-1ubuntu3.2
    • 12.22.9~dfsg-1ubuntu3.3
    • 12.22.9~dfsg-1ubuntu3.4
    • 12.22.9~dfsg-1ubuntu3.5
    • 12.22.9~dfsg-1ubuntu3.6
    • 12.22.9~dfsg-1ubuntu3.6+esm2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • openssl Ubuntu:Pro:FIPS-preview:22.04:LTS

    Versions du logiciel
    • 3.0.2-0ubuntu1.10+Fips1
    • 3.0.2-0ubuntu1.12+Fips1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • openssl-fips Ubuntu:Pro:FIPS-preview:22.04:LTS

    Versions du logiciel
    • 3.0.5-0ubuntu0.1+Fips2.1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • openssl Ubuntu:Pro:FIPS-updates:22.04:LTS

    Versions du logiciel
    • 3.0.2-0ubuntu1.10+Fips1
    • 3.0.2-0ubuntu1.12+Fips1
    • 3.0.2-0ubuntu1.14+Fips1
    • 3.0.2-0ubuntu1.15+Fips1
    • 3.0.2-0ubuntu1.16+Fips1
    Plages de versions concernées
    • ECOSYSTEM: < 3.0.2-0ubuntu1.17+Fips1

    Mettez à jour vers 3.0.2-0ubuntu1.17+Fips1

  • openssl-fips Ubuntu:Pro:FIPS-updates:22.04:LTS

    Versions du logiciel
    • 3.0.5-0ubuntu0.1+Fips2.1
    • 3.0.5-0ubuntu0.2+Fips1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • openssl Ubuntu:24.04:LTS

    Versions du logiciel
    • 3.0.10-1ubuntu2
    • 3.0.10-1ubuntu2.1
    • 3.0.10-1ubuntu3
    • 3.0.10-1ubuntu4
    • 3.0.13-0ubuntu2
    • 3.0.13-0ubuntu3
    • 3.0.13-0ubuntu3.1
    Plages de versions concernées
    • ECOSYSTEM: < 3.0.13-0ubuntu3.2

    Mettez à jour vers 3.0.13-0ubuntu3.2

  • openssl-fips Ubuntu:Pro:FIPS-updates:24.04:LTS

    Versions du logiciel
    • 3.0.13-0ubuntu3+Fips1
    Plages de versions concernées
    • ECOSYSTEM: < 3.0.13-0ubuntu3.6+Fips1

    Mettez à jour vers 3.0.13-0ubuntu3.6+Fips1

Sources originales

Vérifiez votre serveur →