p PatchFirst

CVE-2024-47597

CVE-2024-47597 · GHSL-2024-245: GStreamer has an OOB-read in qtdemux_parse_samples

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

GStreamer is a library for constructing graphs of media-handling components. An OOB-read has been detected in the function qtdemux_parse_samples within qtdemux.c. This issue arises when the function qtdemux_parse_samples reads data beyond the boundaries of the stream->stco buffer. The following code snippet shows the call to qt_atom_parser_get_offset_unchecked, which leads to the OOB-read when parsing the provided GHSL-2024-245_crash1.mp4 file. This issue may lead to read up to 8 bytes out-of-bounds. This vulnerability is fixed in 1.24.10.

CVSS 5.1 · Moyenne · EPSS 1,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • gstreamer

    Versions du logiciel
    • < 1.24.10: Concernée

    Aucun correctif publié

  • gst-plugins-good1.0 Debian:12

    Versions du logiciel
    • 1.22.0-5
    • 1.22.0-5+deb12u1
    Plages de versions concernées
    • ECOSYSTEM: < 1.22.0-5+deb12u2

    Mettez à jour vers 1.22.0-5+deb12u2

  • gst-plugins-good1.0 Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.24.10-1

    Mettez à jour vers 1.24.10-1

  • gst-plugins-good1.0 Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.24.10-1

    Mettez à jour vers 1.24.10-1

  • gst-plugins-good1.0 Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 1.6.0-1ubuntu1
    • 1.6.1-1ubuntu1
    • 1.6.2-1ubuntu1
    • 1.7.1-1ubuntu1
    • 1.7.2-1ubuntu1
    • 1.7.90-1ubuntu1
    • 1.7.91-1ubuntu1
    • 1.8.0-1ubuntu1
    • 1.8.1-1ubuntu0.1
    • 1.8.2-1ubuntu0.1
    • 1.8.2-1ubuntu0.2
    • 1.8.2-1ubuntu0.3
    • 1.8.3-1ubuntu0.3
    • 1.8.3-1ubuntu0.4
    • 1.8.3-1ubuntu0.5
    • 1.8.3-1ubuntu0.5+esm1
    • 1.8.3-1ubuntu0.5+esm2
    • 1.8.3-1ubuntu0.5+esm3
    • 1.8.3-1ubuntu0.5+esm4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • gst-plugins-good0.10 Ubuntu:16.04:LTS

    Versions du logiciel
    • 0.10.31-3+nmu4ubuntu2~gcc5.1
    • 0.10.31-3+nmu4ubuntu2.16.04.1
    • 0.10.31-3+nmu4ubuntu2.16.04.2
    • 0.10.31-3+nmu4ubuntu2.16.04.3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • gst-plugins-good1.0 Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 1.12.3-1ubuntu1
    • 1.12.4-1ubuntu1
    • 1.13.1-1ubuntu1
    • 1.13.91-1ubuntu1
    • 1.14.0-1ubuntu1
    • 1.14.1-1ubuntu1~ubuntu18.04.1
    • 1.14.4-1ubuntu1~ubuntu18.04.1
    • 1.14.5-0ubuntu1~18.04.1
    • 1.14.5-0ubuntu1~18.04.2
    • 1.14.5-0ubuntu1~18.04.3
    • 1.14.5-0ubuntu1~18.04.3+esm1
    • 1.14.5-0ubuntu1~18.04.3+esm2
    • 1.14.5-0ubuntu1~18.04.3+esm3
    • 1.14.5-0ubuntu1~18.04.3+esm4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • gst-plugins-good1.0 Ubuntu:20.04:LTS

    Versions du logiciel
    • 1.16.1-1ubuntu1
    • 1.16.2-1ubuntu1
    • 1.16.2-1ubuntu2
    • 1.16.2-1ubuntu2.1
    • 1.16.3-0ubuntu1
    • 1.16.3-0ubuntu1.1
    • 1.16.3-0ubuntu1.2
    Plages de versions concernées
    • ECOSYSTEM: < 1.16.3-0ubuntu1.3

    Mettez à jour vers 1.16.3-0ubuntu1.3

  • gst-plugins-good1.0 Ubuntu:22.04:LTS

    Versions du logiciel
    • 1.18.5-1ubuntu2
    • 1.18.5-1ubuntu3
    • 1.20.0-2ubuntu1
    • 1.20.1-1ubuntu1
    • 1.20.3-0ubuntu1
    • 1.20.3-0ubuntu1.1
    Plages de versions concernées
    • ECOSYSTEM: < 1.20.3-0ubuntu1.3

    Mettez à jour vers 1.20.3-0ubuntu1.3

  • gst-plugins-good1.0 Ubuntu:24.04:LTS

    Versions du logiciel
    • 1.22.6-1ubuntu1
    • 1.22.6-1ubuntu2
    • 1.22.8-3ubuntu1
    • 1.22.9-1ubuntu1
    • 1.24.0-1ubuntu5
    • 1.24.0-1ubuntu7
    • 1.24.1-2ubuntu1
    • 1.24.2-1ubuntu1
    Plages de versions concernées
    • ECOSYSTEM: < 1.24.2-1ubuntu1.1

    Mettez à jour vers 1.24.2-1ubuntu1.1

Sources originales

Vérifiez votre serveur →