CVE-2024-47834
CVE-2024-47834 · GHSL-2024-280: Gstreamer Use-After-Free read in Matroska CodecPrivate
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
GStreamer is a library for constructing graphs of media-handling components. An Use-After-Free read vulnerability has been discovered affecting the processing of CodecPrivate elements in Matroska streams. In the GST_MATROSKA_ID_CODECPRIVATE case within the gst_matroska_demux_parse_stream function, a data chunk is allocated using gst_ebml_read_binary. Later, the allocated memory is freed in the gst_matroska_track_free function, by the call to g_free (track->codec_priv). Finally, the freed memory is accessed in the caps_serialize function through gst_value_serialize_buffer. The freed memory will be accessed in the gst_value_serialize_buffer function. This results in a UAF read vulnerability, as the function tries to process memory that has already been freed. This vulnerability is fixed in 1.24.10.
CVSS 5.1 · Moyenne · EPSS 0,9% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
gstreamer
- Versions du logiciel
- < 1.24.10: Concernée
Aucun correctif publié
gst-plugins-good1.0 Debian:12
- Versions du logiciel
- 1.22.0-5
- 1.22.0-5+deb12u1
- Plages de versions concernées
- ECOSYSTEM: < 1.22.0-5+deb12u2
Mettez à jour vers 1.22.0-5+deb12u2
gst-plugins-good1.0 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.24.10-1
Mettez à jour vers 1.24.10-1
gst-plugins-good1.0 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.24.10-1
Mettez à jour vers 1.24.10-1
gst-plugins-good1.0 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.6.0-1ubuntu1
- 1.6.1-1ubuntu1
- 1.6.2-1ubuntu1
- 1.7.1-1ubuntu1
- 1.7.2-1ubuntu1
- 1.7.90-1ubuntu1
- 1.7.91-1ubuntu1
- 1.8.0-1ubuntu1
- 1.8.1-1ubuntu0.1
- 1.8.2-1ubuntu0.1
- 1.8.2-1ubuntu0.2
- 1.8.2-1ubuntu0.3
- 1.8.3-1ubuntu0.3
- 1.8.3-1ubuntu0.4
- 1.8.3-1ubuntu0.5
- 1.8.3-1ubuntu0.5+esm1
- 1.8.3-1ubuntu0.5+esm2
- 1.8.3-1ubuntu0.5+esm3
- 1.8.3-1ubuntu0.5+esm4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
gst-plugins-good0.10 Ubuntu:16.04:LTS
- Versions du logiciel
- 0.10.31-3+nmu4ubuntu2~gcc5.1
- 0.10.31-3+nmu4ubuntu2.16.04.1
- 0.10.31-3+nmu4ubuntu2.16.04.2
- 0.10.31-3+nmu4ubuntu2.16.04.3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
gst-plugins-good1.0 Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.12.3-1ubuntu1
- 1.12.4-1ubuntu1
- 1.13.1-1ubuntu1
- 1.13.91-1ubuntu1
- 1.14.0-1ubuntu1
- 1.14.1-1ubuntu1~ubuntu18.04.1
- 1.14.4-1ubuntu1~ubuntu18.04.1
- 1.14.5-0ubuntu1~18.04.1
- 1.14.5-0ubuntu1~18.04.2
- 1.14.5-0ubuntu1~18.04.3
- 1.14.5-0ubuntu1~18.04.3+esm1
- 1.14.5-0ubuntu1~18.04.3+esm2
- 1.14.5-0ubuntu1~18.04.3+esm3
- 1.14.5-0ubuntu1~18.04.3+esm4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
gst-plugins-good1.0 Ubuntu:20.04:LTS
- Versions du logiciel
- 1.16.1-1ubuntu1
- 1.16.2-1ubuntu1
- 1.16.2-1ubuntu2
- 1.16.2-1ubuntu2.1
- 1.16.3-0ubuntu1
- 1.16.3-0ubuntu1.1
- 1.16.3-0ubuntu1.2
- Plages de versions concernées
- ECOSYSTEM: < 1.16.3-0ubuntu1.3
Mettez à jour vers 1.16.3-0ubuntu1.3
gst-plugins-good1.0 Ubuntu:22.04:LTS
- Versions du logiciel
- 1.18.5-1ubuntu2
- 1.18.5-1ubuntu3
- 1.20.0-2ubuntu1
- 1.20.1-1ubuntu1
- 1.20.3-0ubuntu1
- 1.20.3-0ubuntu1.1
- Plages de versions concernées
- ECOSYSTEM: < 1.20.3-0ubuntu1.3
Mettez à jour vers 1.20.3-0ubuntu1.3
gst-plugins-good1.0 Ubuntu:24.04:LTS
- Versions du logiciel
- 1.22.6-1ubuntu1
- 1.22.6-1ubuntu2
- 1.22.8-3ubuntu1
- 1.22.9-1ubuntu1
- 1.24.0-1ubuntu5
- 1.24.0-1ubuntu7
- 1.24.1-2ubuntu1
- 1.24.2-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: < 1.24.2-1ubuntu1.1
Mettez à jour vers 1.24.2-1ubuntu1.1
Sources originales
- https://securitylab.github.com/advisories/GHSL-2024-280_Gstreamer/
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8057.patch
- https://gstreamer.freedesktop.org/security/sa-2024-0030.html
- https://lists.debian.org/debian-lts-announce/2025/02/msg00035.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-47834