CVE-2024-53949
CVE-2024-53949 · Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API. issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.
CVSS 7.6 · Élevée · EPSS 0,7% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
apache superset
- Versions du logiciel
- ≥ 2.0.0, < 4.1.0: Concernée (semver)
Mettez à jour vers 4.1.0
apache-superset PyPI
- Versions du logiciel
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.1.1rc1
- 2.1.1rc2
- 2.1.1rc3
- 2.1.2
- 2.1.3
- 3.0.0
- 3.0.0rc1
- 3.0.0rc2
- 3.0.0rc3
- 3.0.0rc4
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 3.1.0
- 3.1.0rc1
- 3.1.0rc2
- 3.1.0rc3
- 3.1.0rc4
- 3.1.1
- 3.1.2
- 3.1.3
- 4.0.0
- 4.0.0rc1
- 4.0.0rc2
- 4.0.1
- 4.0.2
- 4.1.0rc2
- 4.1.0rc3
- 4.1.0rc4
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.0.0, < 4.1.0
Mettez à jour vers 4.1.0