p PatchFirst

CVE-2024-56332

CVE-2024-56332 · Next.js Vulnerable to Denial of Service (DoS) with Server Actions

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Next.js is a React framework for building full-stack web applications. Starting in version 13.0.0 and prior to versions 13.5.8, 14.2.21, and 15.1.2, Next.js is vulnerable to a Denial of Service (DoS) attack that allows attackers to construct requests that leaves requests to Server Actions hanging until the hosting provider cancels the function execution. This vulnerability can also be used as a Denial of Wallet (DoW) attack when deployed in providers billing by response times. (Note: Next.js server is idle during that time and only keeps the connection open. CPU and memory footprint are low during that time.). Deployments without any protection against long running Server Action invocations are especially vulnerable. Hosting providers like Vercel or Netlify set a default maximum duration on function execution to reduce the risk of excessive billing. This is the same issue as if the incoming HTTP request has an invalid `Content-Length` header or never closes. If the host has no other mitigations to those then this vulnerability is novel. This vulnerability affects only Next.js deployments using Server Actions. The issue was resolved in Next.js 13.5.8, 14.2.21, and 15.1.2. We recommend that users upgrade to a safe version. There are no official workarounds.

CVSS 5.3 · Moyenne · EPSS 0,8% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • next.js

    Versions du logiciel
    • >= 13.0.0, < 13.5.8: Concernée
    • >= 14.0.0, < 14.2.21: Concernée
    • >= 15.0.0, < 15.1.2: Concernée

    Aucun correctif publié

  • next npm

    Plages de versions concernées
    • SEMVER: ≥ 13.0.0, < 13.5.8

    Mettez à jour vers 13.5.8

  • next npm

    Plages de versions concernées
    • SEMVER: ≥ 14.0.0, < 14.2.21

    Mettez à jour vers 14.2.21

  • next npm

    Plages de versions concernées
    • SEMVER: ≥ 15.0.0, < 15.1.2

    Mettez à jour vers 15.1.2

Sources originales

Vérifiez votre serveur →