CVE-2025-22146
CVE-2025-22146 · Improper authentication on SAML SSO process allows user impersonation in sentry
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Sentry is a developer-first error tracking and performance monitoring tool. A critical vulnerability was discovered in the SAML SSO implementation of Sentry. It was reported to us via our private bug bounty program. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. The Sentry SaaS fix was deployed on Jan 14, 2025. For self hosted users; if only a single organization is allowed `(SENTRY_SINGLE_ORGANIZATION = True)`, then no action is needed. Otherwise, users should upgrade to version 25.1.0 or higher. There are no known workarounds for this vulnerability.
CVSS 9.1 · Critique · EPSS 0,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
sentry
- Versions du logiciel
- >= 21.12.0, < 25.1.0: Concernée
Aucun correctif publié
sentry PyPI
- Versions du logiciel
- 21.12.0
- 22.1.0
- 22.10.0
- 22.11.0
- 22.12.0
- 22.2.0
- 22.3.0
- 22.4.0
- 22.5.0
- 22.6.0
- 22.7.0
- 22.8.0
- 22.9.0
- 23.1.0
- 23.1.1
- 23.2.0
- 23.3.0
- 23.3.1
- 23.4.0
- 23.5.0
- 23.5.1
- 23.5.2
- 23.6.0
- 23.6.1
- 23.6.2
- 23.7.0
- 23.7.1
- Plages de versions concernées
- ECOSYSTEM: ≥ 21.12.0, < 25.1.0
Mettez à jour vers 25.1.0