CVE-2025-32375
CVE-2025-32375 · Insecure Deserialization leads to RCE in BentoML's runner server
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
BentoML is a Python library for building online serving systems optimized for AI apps and model inference. Prior to 1.4.8, there was an insecure deserialization in BentoML's runner server. By setting specific headers and parameters in the POST request, it is possible to execute any unauthorized arbitrary code on the server, which will grant the attackers to have the initial access and information disclosure on the server. This vulnerability is fixed in 1.4.8.
CVSS 9.8 · Critique · EPSS 52,4% · Code d’exploitation public · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
bentoml
- Versions du logiciel
- >= 1.0, < 1.4.8: Concernée
Aucun correctif publié
bentoml PyPI
- Versions du logiciel
- 1.0.0
- 1.0.0a1
- 1.0.0a2
- 1.0.0a3
- 1.0.0a4
- 1.0.0a5
- 1.0.0a6
- 1.0.0a7
- 1.0.0rc0
- 1.0.0rc1
- 1.0.0rc2
- 1.0.0rc3
- 1.0.10
- 1.0.11
- 1.0.12
- 1.0.13
- 1.0.14
- 1.0.15
- 1.0.16
- 1.0.17
- 1.0.18
- 1.0.19
- 1.0.2
- 1.0.20
- 1.0.21
- 1.0.22
- 1.0.23
- 1.0.24
- 1.0.25
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.0.8
- 1.0.9
- 1.1.0
- 1.1.1
- 1.1.10
- 1.1.11
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.1.7
- 1.1.8
- 1.1.9
- 1.2.0
- 1.2.0a0
- 1.2.0a1
- 1.2.0a2
- 1.2.0a3
- 1.2.0a4
- 1.2.0a5
- 1.2.0a6
- 1.2.0a7
- 1.2.0rc1
- 1.2.1
- 1.2.10
- 1.2.11
- 1.2.12
- 1.2.13
- 1.2.14
- 1.2.15
- 1.2.16
- 1.2.17
- 1.2.18
- 1.2.19
- 1.2.1a1
- 1.2.2
- 1.2.20
- 1.2.3
- 1.2.4
- 1.2.5
- 1.2.6
- 1.2.7
- 1.2.8
- 1.2.9
- 1.3.0
- 1.3.0a1
- 1.3.0a2
- 1.3.0a3
- 1.3.1
- 1.3.10
- 1.3.11
- 1.3.12
- 1.3.13
- 1.3.14
- 1.3.15
- 1.3.16
- 1.3.17
- 1.3.18
- 1.3.19
- 1.3.2
- 1.3.20
- 1.3.21
- 1.3.22
- 1.3.3
- 1.3.4.post1
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.3.9
- 1.4.0
- 1.4.0a1
- 1.4.0a2
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.4.6
- 1.4.7
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.0.0a1, < 1.4.8
Mettez à jour vers 1.4.8
bentoml PyPI
- Versions du logiciel
- 1.0.0
- 1.0.10
- 1.0.11
- 1.0.12
- 1.0.13
- 1.0.14
- 1.0.15
- 1.0.16
- 1.0.17
- 1.0.18
- 1.0.19
- 1.0.2
- 1.0.20
- 1.0.21
- 1.0.22
- 1.0.23
- 1.0.24
- 1.0.25
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.0.8
- 1.0.9
- 1.1.0
- 1.1.1
- 1.1.10
- 1.1.11
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.1.7
- 1.1.8
- 1.1.9
- 1.2.0
- 1.2.0a0
- 1.2.0a1
- 1.2.0a2
- 1.2.0a3
- 1.2.0a4
- 1.2.0a5
- 1.2.0a6
- 1.2.0a7
- 1.2.0rc1
- 1.2.1
- 1.2.10
- 1.2.11
- 1.2.12
- 1.2.13
- 1.2.14
- 1.2.15
- 1.2.16
- 1.2.17
- 1.2.18
- 1.2.19
- 1.2.1a1
- 1.2.2
- 1.2.20
- 1.2.3
- 1.2.4
- 1.2.5
- 1.2.6
- 1.2.7
- 1.2.8
- 1.2.9
- 1.3.0
- 1.3.0a1
- 1.3.0a2
- 1.3.0a3
- 1.3.1
- 1.3.10
- 1.3.11
- 1.3.12
- 1.3.13
- 1.3.14
- 1.3.15
- 1.3.16
- 1.3.17
- 1.3.18
- 1.3.19
- 1.3.2
- 1.3.20
- 1.3.21
- 1.3.22
- 1.3.3
- 1.3.4.post1
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.3.9
- 1.4.0
- 1.4.0a1
- 1.4.0a2
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.4.6
- 1.4.7
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.0.0, < 1.4.8
Mettez à jour vers 1.4.8