CVE-2025-46346
CVE-2025-46346 · YesWiki Vulnerable to Stored XSS in Comments
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
YesWiki is a wiki system written in PHP. Prior to version 4.5.4, a stored cross-site scripting (XSS) vulnerability was discovered in the application’s comments feature. This issue allows a malicious actor to inject JavaScript payloads that are stored and later executed in the browser of any user viewing the affected comment. The XSS occurs because the application fails to properly sanitize or encode user input submitted to the comments. Notably, the application sanitizes or does not allow execution of `<script>` tags, but does not account for payloads obfuscated using JavaScript block comments like `/* JavaScriptPayload */`. This issue has been patched in version 4.5.4.
CVSS 6.3 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: php
Produits et versions concernés
yeswiki
- Versions du logiciel
- < 4.5.4: Concernée
Aucun correctif publié
yeswiki/yeswiki Packagist
- Versions du logiciel
- 4.2.3
- v4.1.0
- v4.1.1
- v4.1.2
- v4.1.3
- v4.1.4
- v4.1.5
- v4.2.0
- v4.2.1
- v4.2.2
- v4.2.4
- v4.3
- v4.3.1
- v4.4.0
- v4.4.1
- v4.4.2
- v4.4.3
- v4.4.4
- v4.4.5
- v4.5.0
- v4.5.1
- v4.5.2
- v4.5.3
- Plages de versions concernées
- ECOSYSTEM: < 4.5.4
Mettez à jour vers 4.5.4