CVE-2025-46835
CVE-2025-46835 · Git GUI can create and overwrite files for which the user has write permission
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Git GUI allows you to use the Git source control management tools via a GUI. When a user clones an untrusted repository and is tricked into editing a file located in a maliciously named directory in the repository, then Git GUI can create and overwrite files for which the user has write permission. This vulnerability is fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, and 2.50.1.
CVSS 8.5 · Élevée · EPSS 0,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
git-gui
- Versions du logiciel
- < 2.43.7: Concernée
- >= 2.44.0, < 2.44.4: Concernée
- >= 2.45.0, < 2.45.4: Concernée
- >= 2.46.0, < 2.46.4: Concernée
- >= 2.47.0, < 2.47.3: Concernée
- >= 2.48.0, < 2.48.2: Concernée
- >= 2.49.0, < 2.49.1: Concernée
- >= 2.50.0, < 2.50.1: Concernée
Aucun correctif publié
git Debian:12
- Versions du logiciel
- 1:2.39.2+next.20230215-1
- 1:2.39.2-1.1
- 1:2.39.5-0+deb12u1
- 1:2.39.5-0+deb12u2
- Plages de versions concernées
- ECOSYSTEM: < 1:2.39.5-0+deb12u3
Mettez à jour vers 1:2.39.5-0+deb12u3
git Debian:13
- Versions du logiciel
- 1:2.47.2-0.2
- Plages de versions concernées
- ECOSYSTEM: < 1:2.47.3-0+deb13u1
Mettez à jour vers 1:2.47.3-0+deb13u1
git Debian:14
- Versions du logiciel
- 1:2.47.2-0.2
- 1:2.48.0~rc1+next.20250101-1
- 1:2.49.0+next.20250314-1
- 1:2.49.0-1
- 1:2.49.0-2
- 1:2.49.0-3
- 1:2.50.0+next.20250615-1
- 1:2.50.0-1
- 1:2.50.0~rc0+next.20250528-1
- Plages de versions concernées
- ECOSYSTEM: < 1:2.50.1-0.1
Mettez à jour vers 1:2.50.1-0.1
git Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1:2.5.0-1
- 1:2.6.2-1
- 1:2.6.3-1
- 1:2.6.4-1
- 1:2.7.0~rc3-1
- 1:2.7.0-1
- 1:2.7.3-0ubuntu1
- 1:2.7.4-0ubuntu1
- 1:2.7.4-0ubuntu1.1
- 1:2.7.4-0ubuntu1.2
- 1:2.7.4-0ubuntu1.3
- 1:2.7.4-0ubuntu1.4
- 1:2.7.4-0ubuntu1.5
- 1:2.7.4-0ubuntu1.6
- 1:2.7.4-0ubuntu1.7
- 1:2.7.4-0ubuntu1.8
- 1:2.7.4-0ubuntu1.9
- 1:2.7.4-0ubuntu1.10
- 1:2.7.4-0ubuntu1.10+esm1
- 1:2.7.4-0ubuntu1.10+esm3
- 1:2.7.4-0ubuntu1.10+esm4
- 1:2.7.4-0ubuntu1.10+esm5
- 1:2.7.4-0ubuntu1.10+esm6
- 1:2.7.4-0ubuntu1.10+esm7
- 1:2.7.4-0ubuntu1.10+esm8
- 1:2.7.4-0ubuntu1.10+esm9
- 1:2.7.4-0ubuntu1.10+esm10
- Plages de versions concernées
- ECOSYSTEM: < 1:2.7.4-0ubuntu1.10+esm11
Mettez à jour vers 1:2.7.4-0ubuntu1.10+esm11
git Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1:2.14.1-1ubuntu4
- 1:2.15.1-1ubuntu2
- 1:2.17.0-1ubuntu1
- 1:2.17.1-1ubuntu0.1
- 1:2.17.1-1ubuntu0.3
- 1:2.17.1-1ubuntu0.4
- 1:2.17.1-1ubuntu0.5
- 1:2.17.1-1ubuntu0.6
- 1:2.17.1-1ubuntu0.7
- 1:2.17.1-1ubuntu0.8
- 1:2.17.1-1ubuntu0.9
- 1:2.17.1-1ubuntu0.10
- 1:2.17.1-1ubuntu0.11
- 1:2.17.1-1ubuntu0.12
- 1:2.17.1-1ubuntu0.13
- 1:2.17.1-1ubuntu0.14
- 1:2.17.1-1ubuntu0.15
- 1:2.17.1-1ubuntu0.16
- 1:2.17.1-1ubuntu0.17
- 1:2.17.1-1ubuntu0.18
- 1:2.17.1-1ubuntu0.18+esm1
- 1:2.17.1-1ubuntu0.18+esm2
- 1:2.17.1-1ubuntu0.18+esm3
- Plages de versions concernées
- ECOSYSTEM: < 1:2.17.1-1ubuntu0.18+esm4
Mettez à jour vers 1:2.17.1-1ubuntu0.18+esm4
git Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 1:2.20.1-2ubuntu1
- 1:2.24.0-1ubuntu1
- 1:2.24.0-1ubuntu2
- 1:2.25.0-1ubuntu1
- 1:2.25.1-1ubuntu1
- 1:2.25.1-1ubuntu2
- 1:2.25.1-1ubuntu3
- 1:2.25.1-1ubuntu3.1
- 1:2.25.1-1ubuntu3.2
- 1:2.25.1-1ubuntu3.3
- 1:2.25.1-1ubuntu3.4
- 1:2.25.1-1ubuntu3.5
- 1:2.25.1-1ubuntu3.6
- 1:2.25.1-1ubuntu3.7
- 1:2.25.1-1ubuntu3.8
- 1:2.25.1-1ubuntu3.10
- 1:2.25.1-1ubuntu3.11
- 1:2.25.1-1ubuntu3.12
- 1:2.25.1-1ubuntu3.13
- 1:2.25.1-1ubuntu3.14
- 1:2.25.1-1ubuntu3.14+esm1
- 1:2.25.1-1ubuntu3.14+esm2
- Plages de versions concernées
- ECOSYSTEM: < 1:2.25.1-1ubuntu3.14+esm3
Mettez à jour vers 1:2.25.1-1ubuntu3.14+esm3
git Ubuntu:22.04:LTS
- Versions du logiciel
- 1:2.32.0-1ubuntu1
- 1:2.33.1-1ubuntu1
- 1:2.34.1-1ubuntu1
- 1:2.34.1-1ubuntu1.1
- 1:2.34.1-1ubuntu1.2
- 1:2.34.1-1ubuntu1.4
- 1:2.34.1-1ubuntu1.5
- 1:2.34.1-1ubuntu1.6
- 1:2.34.1-1ubuntu1.8
- 1:2.34.1-1ubuntu1.9
- 1:2.34.1-1ubuntu1.10
- 1:2.34.1-1ubuntu1.11
- 1:2.34.1-1ubuntu1.12
- 1:2.34.1-1ubuntu1.13
- 1:2.34.1-1ubuntu1.14
- Plages de versions concernées
- ECOSYSTEM: < 1:2.34.1-1ubuntu1.15
Mettez à jour vers 1:2.34.1-1ubuntu1.15
git Ubuntu:24.04:LTS
- Versions du logiciel
- 1:2.40.1-1ubuntu1
- 1:2.43.0-1ubuntu1
- 1:2.43.0-1ubuntu5
- 1:2.43.0-1ubuntu6
- 1:2.43.0-1ubuntu7
- 1:2.43.0-1ubuntu7.1
- 1:2.43.0-1ubuntu7.2
- Plages de versions concernées
- ECOSYSTEM: < 1:2.43.0-1ubuntu7.3
Mettez à jour vers 1:2.43.0-1ubuntu7.3
Sources originales
- https://github.com/j6t/git-gui/security/advisories/GHSA-xfx7-68v4-v8fg
- https://github.com/j6t/git-gui/compare/dcda716dbc9c90bcac4611bd1076747671ee0906..a437f5bc93330a70b42a230e52f3bd036ca1b1da
- https://lists.debian.org/debian-lts-announce/2025/10/msg00003.html
- http://www.openwall.com/lists/oss-security/2025/07/08/4
- https://nvd.nist.gov/vuln/detail/CVE-2025-46835