CVE-2025-48956
CVE-2025-48956 · vLLM API endpoints vulnerable to Denial of Service Attacks
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.
CVSS 7.5 · Élevée · EPSS 0,6% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
vllm
- Versions du logiciel
- >= 0.1.0, < 0.10.1.1: Concernée
Aucun correctif publié
vllm PyPI
- Versions du logiciel
- 0.1.0
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.1.7
- 0.10.0
- 0.10.1
- 0.2.0
- 0.2.1
- 0.2.1.post1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.2.6
- 0.2.7
- 0.3.0
- 0.3.1
- 0.3.2
- 0.3.3
- 0.4.0
- 0.4.0.post1
- 0.4.1
- 0.4.2
- 0.4.3
- 0.5.0
- 0.5.0.post1
- 0.5.1
- 0.5.2
- 0.5.3
- 0.5.3.post1
- 0.5.4
- 0.5.5
- 0.6.0
- 0.6.1
- 0.6.1.post1
- 0.6.1.post2
- 0.6.2
- 0.6.3
- 0.6.3.post1
- 0.6.4
- 0.6.4.post1
- 0.6.5
- 0.6.6
- 0.6.6.post1
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.5.post1
- 0.9.0
- 0.9.0.1
- 0.9.1
- 0.9.2
- Plages de versions concernées
- ECOSYSTEM: ≥ 0.1.0, < 0.10.1.1
Mettez à jour vers 0.10.1.1