p PatchFirst

CVE-2025-54417

CVE-2025-54417 · Craft contains a theoretical bypass for CVE-2025-23209

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Craft is a platform for creating digital experiences. Versions 4.13.8 through 4.16.2 and 5.5.8 through 5.8.3 contain a vulnerability that can bypass CVE-2025-23209: "Craft CMS has a potential RCE with a compromised security key". To exploit this vulnerability, the project must meet these requirements: have a compromised security key and create an arbitrary file in Craft's /storage/backups folder. With those criteria in place, attackers could create a specific, malicious request to the /updater/restore-db endpoint and execute CLI commands remotely. This issue is fixed in versions 4.16.3 and 5.8.4.

CVSS 5.2 · Moyenne · EPSS 0,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: php

Produits et versions concernés

  • cms

    Versions du logiciel
    • >= 4.13.8, < 4.16.3: Concernée
    • >= 5.5.8, < 5.8.4: Concernée

    Aucun correctif publié

  • craftcms/cms Packagist

    Versions du logiciel
    • 4.13.10
    • 4.13.8
    • 4.13.9
    • 4.14.0
    • 4.14.0.1
    • 4.14.0.2
    • 4.14.1
    • 4.14.10
    • 4.14.11
    • 4.14.11.1
    • 4.14.12
    • 4.14.13
    • 4.14.14
    • 4.14.15
    • 4.14.2
    • 4.14.3
    • 4.14.4
    • 4.14.5
    • 4.14.6
    • 4.14.7
    • 4.14.8
    • 4.14.8.1
    • 4.14.9
    • 4.15.0
    • 4.15.0-beta.1
    • 4.15.0-beta.2
    • 4.15.0.1
    • 4.15.0.2
    • 4.15.1
    • 4.15.2
    • 4.15.3
    • 4.15.4
    • 4.15.5
    • 4.15.6
    • 4.15.6.1
    • 4.15.6.2
    • 4.15.7
    • 4.16.0
    • 4.16.1
    • 4.16.2
    Plages de versions concernées
    • ECOSYSTEM: ≥ 4.13.8, < 4.16.3

    Mettez à jour vers 4.16.3

  • craftcms/cms Packagist

    Versions du logiciel
    • 5.5.10
    • 5.5.8
    • 5.5.9
    • 5.6.0
    • 5.6.0.1
    • 5.6.0.2
    • 5.6.1
    • 5.6.10
    • 5.6.10.1
    • 5.6.10.2
    • 5.6.11
    • 5.6.12
    • 5.6.13
    • 5.6.14
    • 5.6.15
    • 5.6.16
    • 5.6.17
    • 5.6.2
    • 5.6.3
    • 5.6.4
    • 5.6.5
    • 5.6.5.1
    • 5.6.6
    • 5.6.7
    • 5.6.8
    • 5.6.9
    • 5.6.9.1
    • 5.7.0
    • 5.7.0-beta.1
    • 5.7.0-beta.2
    • 5.7.1
    • 5.7.1.1
    • 5.7.10
    • 5.7.11
    • 5.7.2
    • 5.7.3
    • 5.7.4
    • 5.7.5
    • 5.7.6
    • 5.7.7
    • 5.7.8
    • 5.7.8.1
    • 5.7.8.2
    • 5.7.9
    • 5.8.0
    • 5.8.1
    • 5.8.2
    • 5.8.3
    Plages de versions concernées
    • ECOSYSTEM: ≥ 5.5.8, < 5.8.4

    Mettez à jour vers 5.8.4

Sources originales

Vérifiez votre serveur →