CVE-2025-62372
CVE-2025-62372 · vLLM vulnerable to DoS with incorrect shape of multimodal embedding inputs
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.
CVSS 8.3 · Élevée · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python
Produits et versions concernés
vllm
- Versions du logiciel
- >= 0.5.5, < 0.11.1: Concernée
Aucun correctif publié
vllm PyPI
- Versions du logiciel
- 0.10.0
- 0.10.1
- 0.10.1.1
- 0.10.2
- 0.11.0
- 0.5.5
- 0.6.0
- 0.6.1
- 0.6.1.post1
- 0.6.1.post2
- 0.6.2
- 0.6.3
- 0.6.3.post1
- 0.6.4
- 0.6.4.post1
- 0.6.5
- 0.6.6
- 0.6.6.post1
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.5.post1
- 0.9.0
- 0.9.0.1
- 0.9.1
- 0.9.2
- Plages de versions concernées
- ECOSYSTEM: ≥ 0.5.5, < 0.11.1
Mettez à jour vers 0.11.1
Sources originales
- https://github.com/vllm-project/vllm/security/advisories/GHSA-pmqf-x6x8-p7qw
- https://github.com/vllm-project/vllm/pull/27204
- https://github.com/vllm-project/vllm/pull/6613
- https://github.com/vllm-project/vllm/commit/58fab50d82838d5014f4a14d991fdb9352c9c84b
- https://nvd.nist.gov/vuln/detail/CVE-2025-62372