p PatchFirst

CVE-2025-62508

CVE-2025-62508 · Citizen vulnerable to stored XSS in sticky header button messages

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. Citizen from 3.3.0 to 3.9.0 are vulnerable to stored cross-site scripting in the sticky header button message handling. In stickyHeader.js the copyButtonAttributes function assigns innerHTML from a source element’s textContent when copying button labels. This causes escaped HTML in system message content (such as citizen-share, citizen-view-history, citizen-view-edit, and nstab-talk) to be interpreted as HTML in the sticky header, allowing injection of arbitrary script by a user with the ability to edit interface messages. The vulnerability allows a user with the editinterface right but without the editsitejs right (by default the sysop group has editinterface but may not have editsitejs) to execute arbitrary JavaScript in other users’ sessions, enabling unauthorized access to sensitive data or actions. The issue is fixed in 3.9.0.

CVSS 6.5 · Moyenne · EPSS 0,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: php

Produits et versions concernés

  • mediawiki-skins-citizen

    Versions du logiciel
    • >= 3.3.0, < 3.9.0: Concernée

    Aucun correctif publié

  • starcitizentools/citizen-skin Packagist

    Versions du logiciel
    • v3.3.0
    • v3.3.1
    • v3.3.2
    • v3.4.0
    • v3.5.0
    • v3.6.0
    • v3.7.0
    • v3.8.0
    Plages de versions concernées
    • ECOSYSTEM: ≥ 3.3.0, < 3.9.0

    Mettez à jour vers 3.9.0

Sources originales

Vérifiez votre serveur →