p PatchFirst

CVE-2025-64340

CVE-2025-64340 · FastMCP has a Command Injection vulnerability - Gemini CLI

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

FastMCP is the standard framework for building MCP applications. Prior to version 3.2.0, server names containing shell metacharacters (e.g., &) can cause command injection on Windows when passed to fastmcp install claude-code or fastmcp install gemini-cli. These install paths use subprocess.run() with a list argument, but on Windows the target CLIs often resolve to .cmd wrappers that are executed through cmd.exe, which interprets metacharacters in the flattened command string. This issue has been patched in version 3.2.0.

CVSS 6.7 · Moyenne · EPSS 0,7% · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • fastmcp

    Versions du logiciel
    • < 3.2.0: Concernée

    Aucun correctif publié

  • fastmcp PyPI

    Versions du logiciel
    • 0.1.0
    • 0.2.0
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    • 0.4.0
    • 0.4.1
    • 1.0
    • 2.0.0
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.10.0
    • 2.10.1
    • 2.10.2
    • 2.10.3
    • 2.10.4
    • 2.10.5
    • 2.10.6
    • 2.11.0
    • 2.11.1
    • 2.11.2
    • 2.11.3
    • 2.12.0
    • 2.12.0rc1
    • 2.12.1
    • 2.12.2
    • 2.12.3
    • 2.12.4
    • 2.12.5
    • 2.13.0
    • 2.13.0.1
    • 2.13.0.2
    • 2.13.0rc1
    • 2.13.0rc2
    • 2.13.0rc3
    • 2.13.1
    • 2.13.2
    • 2.13.3
    • 2.14.0
    • 2.14.1
    • 2.14.2
    • 2.14.3
    • 2.14.4
    • 2.14.5
    • 2.14.6
    • 2.14.7
    • 2.2.0
    • 2.2.1
    • 2.2.10
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 2.2.5
    • 2.2.6
    • 2.2.7
    • 2.2.8
    • 2.2.9
    • 2.3.0
    • 2.3.0rc1
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.3.5
    • 2.4.0
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.6.0
    • 2.6.1
    • 2.7.0
    • 2.7.1
    • 2.8.0
    • 2.8.1
    • 2.9.0
    • 2.9.1
    • 2.9.2
    • 3.0.0
    • 3.0.0b1
    • 3.0.0b2
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.0.0rc3
    • 3.0.1
    • 3.0.2
    • 3.1.0
    • 3.1.1
    Plages de versions concernées
    • ECOSYSTEM: < 3.2.0

    Mettez à jour vers 3.2.0

Sources originales

Vérifiez votre serveur →