p PatchFirst

CVE-2025-66648

CVE-2025-66648 · `vega-functions` vulnerable to Cross-site Scripting via `setdata` function

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

vega-functions provides function implementations for the Vega expression language. Prior to version 6.1.1, for sites that allow users to supply untrusted user input, malicious use of an internal function (not part of the public API) could be used to run unintentional javascript (XSS). This issue is fixed in vega-functions `6.1.1`. There is no workaround besides upgrading. Using `vega.expressionInterpreter` as described in CSP safe mode does not prevent this issue.

CVSS 7.2 · Élevée · EPSS 0,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • vega

    Versions du logiciel
    • < 6.1.1: Concernée

    Aucun correctif publié

  • vega.js Debian:12

    Versions du logiciel
    • 5.22.1+ds+~3.1.0-4
    • 5.25.0+ds+~cs5.3.0-1
    • 5.25.0+ds+~cs5.3.0-2
    • 5.25.0+ds+~cs5.3.0-3
    • 5.25.0+ds+~cs5.3.0-4
    • 5.25.0+ds+~cs5.3.0-5
    • 5.28.0+ds+~cs5.3.0-1
    • 5.28.0+ds+~cs5.3.0-2
    • 5.28.0+ds+~cs5.3.0-3
    • 5.33.1+ds+~cs5.3.0-1
    • 5.33.1+ds+~cs5.3.0-2
    • 5.33.1+ds+~cs5.3.0-3
    • 5.33.1+ds+~cs5.3.0-4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • vega.js Debian:13

    Versions du logiciel
    • 5.28.0+ds+~cs5.3.0-1
    • 5.28.0+ds+~cs5.3.0-2
    • 5.28.0+ds+~cs5.3.0-3
    • 5.33.1+ds+~cs5.3.0-1
    • 5.33.1+ds+~cs5.3.0-2
    • 5.33.1+ds+~cs5.3.0-3
    • 5.33.1+ds+~cs5.3.0-4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • vega.js Debian:14

    Versions du logiciel
    • 5.28.0+ds+~cs5.3.0-1
    • 5.28.0+ds+~cs5.3.0-2
    • 5.28.0+ds+~cs5.3.0-3
    • 5.33.1+ds+~cs5.3.0-1
    Plages de versions concernées
    • ECOSYSTEM: < 5.33.1+ds+~cs5.3.0-2

    Mettez à jour vers 5.33.1+ds+~cs5.3.0-2

  • vega-functions npm

    Plages de versions concernées
    • SEMVER: < 6.1.1

    Mettez à jour vers 6.1.1

  • vega.js Ubuntu:24.04:LTS

    Versions du logiciel
    • 5.25.0+ds+~cs5.3.0-2
    • 5.25.0+ds+~cs5.3.0-5
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • vega.js Ubuntu:25.10

    Versions du logiciel
    • 5.28.0+ds+~cs5.3.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • vega.js Ubuntu:26.10

    Versions du logiciel
    • 5.28.0+ds+~cs5.3.0-2
    • 5.33.1+ds+~cs5.3.0-4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • vega.js Ubuntu:26.04:LTS

    Versions du logiciel
    • 5.28.0+ds+~cs5.3.0-1
    • 5.28.0+ds+~cs5.3.0-2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →