p PatchFirst

CVE-2025-68158

CVE-2025-68158 · Authlib: 1-click Account Takeover

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Authlib is a Python library which builds OAuth and OpenID Connect servers. In versions 1.0.0 through 1.6.5, cache-backed state/request-token storage is not tied to the initiating user session, so CSRF is possible for any attacker that has a valid state (easily obtainable via an attacker-initiated authentication flow). When a cache is supplied to the OAuth client registry, FrameworkIntegration.set_state_data writes the entire state blob under _state_{app}_{state}, and get_state_data ignores the caller’s session altogether. This issue has been patched in version 1.6.6.

CVSS 5.7 · Moyenne · EPSS 0,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · python

Produits et versions concernés

  • authlib

    Versions du logiciel
    • >= 1.0.0, < 1.6.6: Concernée

    Aucun correctif publié

  • python-authlib Debian:12

    Versions du logiciel
    • 1.2.0-1
    Plages de versions concernées
    • ECOSYSTEM: < 1.2.0-1+deb12u1

    Mettez à jour vers 1.2.0-1+deb12u1

  • python-authlib Debian:13

    Versions du logiciel
    • 1.6.0-1
    Plages de versions concernées
    • ECOSYSTEM: < 1.6.0-1+deb13u1

    Mettez à jour vers 1.6.0-1+deb13u1

  • python-authlib Debian:14

    Versions du logiciel
    • 1.6.0-1
    • 1.6.1-1
    • 1.6.3-1
    • 1.6.4-1
    • 1.6.5-1
    Plages de versions concernées
    • ECOSYSTEM: < 1.6.6-1

    Mettez à jour vers 1.6.6-1

  • authlib PyPI

    Versions du logiciel
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.2.1
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.0.0, < 1.6.6

    Mettez à jour vers 1.6.6

  • python-authlib Ubuntu:Pro:24.04:LTS

    Versions du logiciel
    • 1.2.1-1
    • 1.3.0-1
    Plages de versions concernées
    • ECOSYSTEM: < 1.3.0-1ubuntu0.1~esm1

    Mettez à jour vers 1.3.0-1ubuntu0.1~esm1

  • python-authlib Ubuntu:25.10

    Versions du logiciel
    • 1.5.1-1
    • 1.5.2-1
    • 1.6.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →