p PatchFirst

CVE-2025-8715

CVE-2025-8715 · PostgreSQL pg_dump newline in object name executes arbitrary code in psql client and in restore target server

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Improper neutralization of newlines in pg_dump in PostgreSQL allows a user of the origin server to inject arbitrary code for restore-time execution as the client operating system account running psql to restore the dump, via psql meta-commands inside a purpose-crafted object name. The same attacks can achieve SQL injection as a superuser of the restore target server. pg_dumpall, pg_restore, and pg_upgrade are also affected. Versions before PostgreSQL 17.6, 16.10, 15.14, 14.19, and 13.22 are affected. Versions before 11.20 are unaffected. CVE-2012-0868 had fixed this class of problem, but version 11.20 reintroduced it.

CVSS 8.8 · Élevée · EPSS 0,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · database

Produits et versions concernés

  • postgresql

    Versions du logiciel
    • ≥ 17, < 17.6: Concernée (rpm)
    • ≥ 16, < 16.10: Concernée (rpm)
    • ≥ 15, < 15.14: Concernée (rpm)
    • ≥ 14, < 14.19: Concernée (rpm)
    • ≥ 11.20, < 13.22: Concernée (rpm)

    Mettez à jour vers 13.22; Mettez à jour vers 14.19; Mettez à jour vers 15.14; Mettez à jour vers 16.10; Mettez à jour vers 17.6

  • postgresql-15 Debian:12

    Versions du logiciel
    • 15.10-0+deb12u1
    • 15.11-0+deb12u1
    • 15.12-0+deb12u1
    • 15.12-0+deb12u2
    • 15.13-0+deb12u1
    • 15.3-0+deb12u1
    • 15.3-1
    • 15.4-0+deb12u1
    • 15.4-1
    • 15.4-2
    • 15.4-3
    • 15.5-0+deb12u1
    • 15.6-0+deb12u1
    • 15.7-0+deb12u1
    • 15.8-0+deb12u1
    • 15.9-0+deb12u1
    Plages de versions concernées
    • ECOSYSTEM: < 15.14-0+deb12u1

    Mettez à jour vers 15.14-0+deb12u1

  • postgresql-17 Debian:13

    Versions du logiciel
    • 17.5-1
    Plages de versions concernées
    • ECOSYSTEM: < 17.6-0+deb13u1

    Mettez à jour vers 17.6-0+deb13u1

  • postgresql-9.3 Ubuntu:Pro:14.04:LTS

    Versions du logiciel
    • 9.3.1-1
    • 9.3.2-1
    • 9.3.2-1ubuntu1
    • 9.3.2-1ubuntu2
    • 9.3.3-1
    • 9.3.3-1bzr1
    • 9.3.3-1bzr2
    • 9.3.4-1
    • 9.3.5-0ubuntu0.14.04.1
    • 9.3.6-0ubuntu0.14.04
    • 9.3.7-0ubuntu0.14.04
    • 9.3.8-0ubuntu0.4.04
    • 9.3.9-0ubuntu0.14.04
    • 9.3.10-0ubuntu0.14.04
    • 9.3.11-0ubuntu0.14.04
    • 9.3.12-0ubuntu0.14.04
    • 9.3.13-0ubuntu0.14.04
    • 9.3.14-0ubuntu0.14.04
    • 9.3.15-0ubuntu0.14.04
    • 9.3.16-0ubuntu0.14.04
    • 9.3.17-0ubuntu0.14.04
    • 9.3.18-0ubuntu0.14.04.1
    • 9.3.19-0ubuntu0.14.04
    • 9.3.20-0ubuntu0.14.04
    • 9.3.21-0ubuntu0.14.04
    • 9.3.22-0ubuntu0.14.04
    • 9.3.23-0ubuntu0.14.04
    • 9.3.24-0ubuntu0.14.04
    • 9.3.24-0ubuntu0.14.04+esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • postgresql-9.5 Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 9.5.0-1
    • 9.5.0-2
    • 9.5.0-3
    • 9.5.1-1
    • 9.5.2-1
    • 9.5.3-0ubuntu0.16.04
    • 9.5.4-0ubuntu0.16.04
    • 9.5.5-0ubuntu0.16.04
    • 9.5.6-0ubuntu0.16.04
    • 9.5.7-0ubuntu0.16.04
    • 9.5.8-0ubuntu0.16.04.1
    • 9.5.9-0ubuntu0.16.04
    • 9.5.10-0ubuntu0.16.04
    • 9.5.11-0ubuntu0.16.04
    • 9.5.12-0ubuntu0.16.04
    • 9.5.13-0ubuntu0.16.04
    • 9.5.14-0ubuntu0.16.04
    • 9.5.16-0ubuntu0.16.04.1
    • 9.5.17-0ubuntu0.16.04.1
    • 9.5.18-0ubuntu0.16.04.1
    • 9.5.19-0ubuntu0.16.04.1
    • 9.5.21-0ubuntu0.16.04.1
    • 9.5.23-0ubuntu0.16.04.1
    • 9.5.24-0ubuntu0.16.04.1
    • 9.5.25-0ubuntu0.16.04.1
    • 9.5.25-0ubuntu0.16.04.1+esm1
    • 9.5.25-0ubuntu0.16.04.1+esm2
    • 9.5.25-0ubuntu0.16.04.1+esm3
    • 9.5.25-0ubuntu0.16.04.1+esm4
    • 9.5.25-0ubuntu0.16.04.1+esm5
    • 9.5.25-0ubuntu0.16.04.1+esm6
    • 9.5.25-0ubuntu0.16.04.1+esm7
    • 9.5.25-0ubuntu0.16.04.1+esm8
    • 9.5.25-0ubuntu0.16.04.1+esm10
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • postgresql-10 Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 10.1-1
    • 10.1-2
    • 10.2-1
    • 10.3-1
    • 10.4-0ubuntu0.18.04
    • 10.5-0ubuntu0.18.04
    • 10.6-0ubuntu0.18.04.1
    • 10.7-0ubuntu0.18.04.1
    • 10.8-0ubuntu0.18.04.1
    • 10.9-0ubuntu0.18.04.1
    • 10.10-0ubuntu0.18.04.1
    • 10.12-0ubuntu0.18.04.1
    • 10.14-0ubuntu0.18.04.1
    • 10.15-0ubuntu0.18.04.1
    • 10.16-0ubuntu0.18.04.1
    • 10.17-0ubuntu0.18.04.1
    • 10.18-0ubuntu0.18.04.1
    • 10.19-0ubuntu0.18.04.1
    • 10.20-0ubuntu0.18.04.1
    • 10.21-0ubuntu0.18.04.1
    • 10.22-0ubuntu0.18.04.1
    • 10.23-0ubuntu0.18.04.1
    • 10.23-0ubuntu0.18.04.2
    • 10.23-0ubuntu0.18.04.2+esm1
    • 10.23-0ubuntu0.18.04.2+esm2
    • 10.23-0ubuntu0.18.04.2+esm3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • postgresql-12 Ubuntu:20.04:LTS

    Versions du logiciel
    • 12.0-1
    • 12.1-1
    • 12.1-2build1
    • 12.2-1
    • 12.2-1ubuntu2
    • 12.2-4
    • 12.4-0ubuntu0.20.04.1
    • 12.5-0ubuntu0.20.04.1
    • 12.6-0ubuntu0.20.04.1
    • 12.7-0ubuntu0.20.04.1
    • 12.8-0ubuntu0.20.04.1
    • 12.9-0ubuntu0.20.04.1
    • 12.10-0ubuntu0.20.04.1
    • 12.11-0ubuntu0.20.04.1
    • 12.12-0ubuntu0.20.04.1
    • 12.13-0ubuntu0.20.04.1
    • 12.14-0ubuntu0.20.04.1
    • 12.15-0ubuntu0.20.04.1
    • 12.16-0ubuntu0.20.04.1
    • 12.17-0ubuntu0.20.04.1
    • 12.18-0ubuntu0.20.04.1
    • 12.19-0ubuntu0.20.04.1
    • 12.20-0ubuntu0.20.04.1
    • 12.22-0ubuntu0.20.04.1
    • 12.22-0ubuntu0.20.04.2
    • 12.22-0ubuntu0.20.04.4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • postgresql-14 Ubuntu:22.04:LTS

    Versions du logiciel
    • 14.1-1ubuntu1
    • 14.2-1
    • 14.2-1ubuntu1
    • 14.3-0ubuntu0.22.04.1
    • 14.4-0ubuntu0.22.04.1
    • 14.5-0ubuntu0.22.04.1
    • 14.6-0ubuntu0.22.04.1
    • 14.7-0ubuntu0.22.04.1
    • 14.8-0ubuntu0.22.04.1
    • 14.9-0ubuntu0.22.04.1
    • 14.10-0ubuntu0.22.04.1
    • 14.11-0ubuntu0.22.04.1
    • 14.12-0ubuntu0.22.04.1
    • 14.13-0ubuntu0.22.04.1
    • 14.15-0ubuntu0.22.04.1
    • 14.17-0ubuntu0.22.04.1
    • 14.18-0ubuntu0.22.04.1
    Plages de versions concernées
    • ECOSYSTEM: < 14.19-0ubuntu0.22.04.1

    Mettez à jour vers 14.19-0ubuntu0.22.04.1

  • postgresql-16 Ubuntu:24.04:LTS

    Versions du logiciel
    • 16.0-2
    • 16.1-1
    • 16.1-1build1
    • 16.1-1build3
    • 16.2-1
    • 16.2-1ubuntu2
    • 16.2-1ubuntu3
    • 16.2-1ubuntu4
    • 16.3-0ubuntu0.24.04.1
    • 16.4-0ubuntu0.24.04.1
    • 16.4-0ubuntu0.24.04.2
    • 16.6-0ubuntu0.24.04.1
    • 16.8-0ubuntu0.24.04.1
    • 16.9-0ubuntu0.24.04.1
    Plages de versions concernées
    • ECOSYSTEM: < 16.10-0ubuntu0.24.04.1

    Mettez à jour vers 16.10-0ubuntu0.24.04.1

  • postgresql-17 Ubuntu:25.10

    Versions du logiciel
    • 17.4-1
    • 17.4-2
    • 17.5-1
    • 17.5-1build1
    Plages de versions concernées
    • ECOSYSTEM: < 17.6-1

    Mettez à jour vers 17.6-1

Sources originales

Vérifiez votre serveur →