CVE-2026-100697
CVE-2026-100697 · Adminer 6.0.0 Server-Side Request Forgery via ClickHouse driver
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Adminer 6.0.0 through 6.0.1, when the official ClickHouse driver plugin (plugins/drivers/clickhouse.php, rewritten in 6.0.0) is loaded, is vulnerable to pre-authentication server-side request forgery. An unauthenticated attacker can submit auth[driver]=clickhouse with auth[server] set to an arbitrary URL (for example http://127.0.0.1:18089), causing the Adminer server to issue an HTTP POST containing 'SELECT version()' to that host. In rootQuery(), if the target returns a status outside 200-299 (other than 401/403), the raw HTTP response body is assigned to the connection error and rendered on the login page, so the attacker receives the full response body of the internal service. This enables internal network/port reconnaissance and disclosure of sensitive information contained in internal error pages (stack traces, internal hostnames, file paths, configuration identifiers). Fixed in Adminer 6.0.2.
CVSS 5.3 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
adminer
- Versions du logiciel
- ≥ 0, < 6.0.2: Concernée (semver)
- 6.0.2: Non concernée (semver)
Mettez à jour vers 6.0.2
adminer Debian:12
- Versions du logiciel
- 4.8.1-1
- 4.8.1-2
- 4.8.1-4
- 5.1.0-1
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.3+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- 6.0.1-1
- 6.0.2-1
- 6.1.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
adminer Debian:13
- Versions du logiciel
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.3+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- 6.0.1-1
- 6.0.2-1
- 6.1.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
adminer Debian:14
- Versions du logiciel
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.3+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- 6.0.1-1
- Plages de versions concernées
- ECOSYSTEM: < 6.0.2-1
Mettez à jour vers 6.0.2-1
adminer Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 4.2.1-1
- 4.2.1-1ubuntu1
- 4.2.1-1ubuntu1+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
adminer Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 4.3.1-2
- 4.5.0-1
- 4.6.1-1
- 4.6.2-1
- 4.6.2-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
adminer Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 4.7.2-1
- 4.7.4-1
- 4.7.5-1
- 4.7.6-1
- 4.7.6-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
adminer Ubuntu:22.04:LTS
- Versions du logiciel
- 4.7.9-2
- 4.8.1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
adminer Ubuntu:24.04:LTS
- Versions du logiciel
- 4.8.1-1
- 4.8.1-1ubuntu1
- 4.8.1-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
adminer Ubuntu:26.10
- Versions du logiciel
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
adminer Ubuntu:26.04:LTS
- Versions du logiciel
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié