p PatchFirst

CVE-2026-110180

CVE-2026-110180 · fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions from 2.4.2 through 2.4.7, from 3.1.3 through 3.1.8, and from 4.0.1 through 4.2.2, for HTTP-family schemes the canonicalizeHost() function passes the parsed host to the WHATWG URL parser and adopts its hostname without checking that the parser consumed the entire input as a host, so the authority can be silently rewritten: data before an at-sign is dropped and tab, carriage-return, and line-feed characters are stripped, with no error reported. An application that enforces host-based policy such as denylists, loopback filtering, redirect validation, or outbound proxy routing on one representation can then see the canonical host diverge from what it checked, allowing traffic to be steered to an unintended destination. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, reject an authority that contains more than one at-sign or any tab, carriage-return, or line-feed before calling fast-uri, or treat any non-empty parse error as fatal and compare hosts only from the same parse result.

CVSS 4.8 · Moyenne · EPSS 0,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • fast-uri

    Versions du logiciel
    • ≥ 2.4.2, < 2.4.8: Concernée (semver)
    • 2.4.8: Non concernée (semver)
    • ≥ 3.1.3, < 3.1.9: Concernée (semver)
    • 3.1.9: Non concernée (semver)
    • ≥ 4.0.1, < 4.2.3: Concernée (semver)
    • 4.2.3: Non concernée (semver)

    Mettez à jour vers 2.4.8; Mettez à jour vers 3.1.9; Mettez à jour vers 4.2.3

  • node-ajv Debian:12

    Versions du logiciel
    • 6.12.6-3
    • 8.11.2~ds+~2.1.1-1
    • 8.12.0~ds+~2.1.1-1
    • 8.12.0~ds+~2.1.1-2
    • 8.12.0~ds+~2.1.1-3
    • 8.12.0~ds+~2.1.1-4
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    • 8.20.0~ds+~cs7.1.6-2
    • 8.20.0~ds+~cs7.2.4-1
    • 8.8.2~ds+~2.1.1-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Debian:13

    Versions du logiciel
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    • 8.20.0~ds+~cs7.1.6-2
    • 8.20.0~ds+~cs7.2.4-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Debian:14

    Versions du logiciel
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    • 8.20.0~ds+~cs7.1.6-2
    Plages de versions concernées
    • ECOSYSTEM: < 8.20.0~ds+~cs7.2.4-1

    Mettez à jour vers 8.20.0~ds+~cs7.2.4-1

  • fast-uri npm

    Plages de versions concernées
    • SEMVER: ≥ 2.4.2, < 2.4.8

    Mettez à jour vers 2.4.8

  • fast-uri npm

    Plages de versions concernées
    • SEMVER: ≥ 3.1.3, < 3.1.9

    Mettez à jour vers 3.1.9

  • fast-uri npm

    Plages de versions concernées
    • SEMVER: ≥ 4.0.1, < 4.2.3

    Mettez à jour vers 4.2.3

Sources originales

Vérifiez votre serveur →