CVE-2026-111756
CVE-2026-111756 · follow-redirects array-form headers bypass cross-origin credential stripping
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
follow-redirects is a Node.js HTTP and HTTPS client wrapper that automatically follows redirects. From version 1.16.0 to before version 1.16.1, follow-redirects removes sensitive credential headers (Authorization, Proxy-Authorization, Cookie, and any caller-declared sensitiveHeaders) before following a redirect that crosses to a different host or downgrades to a less secure protocol. The removal routine iterates the caller's headers container with for...in and matches header names against a filter. This assumes the headers container is a plain object keyed by header names. Node's underlying http.request, which follow-redirects is a drop-in replacement for, also accepts headers as an alternating array of names and values. For an array, for...in yields the numeric indices "0", "1", "2" and so on, which never match a header-name filter, so nothing is removed. An application that sends array-form headers and follows an attacker-controlled cross-origin redirect therefore forwards its Authorization, Cookie, and Proxy-Authorization headers verbatim to the attacker-controlled destination, with no error or warning. The sensitiveHeaders option added to fix CVE-2026-40895 / GHSA-r4q5-vmmm-2653 is equally ineffective, because it relies on the same helper. This is an unauthenticated confidentiality vulnerability: any remote server the victim application contacts can harvest the victim's credential headers by responding with a cross-origin redirect. This issue has been patched in version 1.16.1.
CVSS 8.2 · Élevée · EPSS 0,5% · Code d’exploitation public · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
follow-redirects
- Versions du logiciel
- >= 1.16.0, < 1.16.1: Concernée
Aucun correctif publié
node-follow-redirects Debian:12
- Versions du logiciel
- 1.15.11+~1.14.4-1
- 1.15.11+~1.14.4-2
- 1.15.2+~1.14.1-1
- 1.15.3+~1.14.2-1
- 1.15.6+~1.14.4-1
- 1.15.6+~1.14.4-2
- 1.15.9+~1.14.4-1
- 1.16.0+~1.14.4-1
- 1.16.0+~1.14.4-2
- 1.16.1+~1.14.4-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-follow-redirects Debian:13
- Versions du logiciel
- 1.15.11+~1.14.4-1
- 1.15.11+~1.14.4-2
- 1.15.9+~1.14.4-1
- 1.16.0+~1.14.4-1
- 1.16.0+~1.14.4-2
- 1.16.1+~1.14.4-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-follow-redirects Debian:14
- Versions du logiciel
- 1.15.11+~1.14.4-1
- 1.15.11+~1.14.4-2
- 1.15.9+~1.14.4-1
- 1.16.0+~1.14.4-1
- 1.16.0+~1.14.4-2
- Plages de versions concernées
- ECOSYSTEM: < 1.16.1+~1.14.4-1
Mettez à jour vers 1.16.1+~1.14.4-1
follow-redirects npm
- Plages de versions concernées
- SEMVER: ≥ 1.16.0, < 1.16.1
Mettez à jour vers 1.16.1
node-follow-redirects Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.2.4-1
- 1.2.4-1ubuntu0.18.04.1~esm1
- 1.2.4-1ubuntu0.18.04.1~esm2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-follow-redirects Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 1.2.4-1
- 1.2.4-1ubuntu0.20.04.1~esm1
- 1.2.4-1ubuntu0.20.04.1~esm2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-follow-redirects Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 1.13.1-1
- 1.14.5-1
- 1.14.7+~1.13.1-1
- 1.14.8+~1.14.0-1
- 1.14.9+~1.14.1-1
- 1.14.9+~1.14.1-1ubuntu0.1~esm1
- 1.14.9+~1.14.1-1ubuntu0.1~esm2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-follow-redirects Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 1.15.2+~1.14.1-1
- 1.15.3+~1.14.2-1
- 1.15.6+~1.14.4-1
- 1.15.6+~1.14.4-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-follow-redirects Ubuntu:26.10
- Versions du logiciel
- 1.15.11+~1.14.4-1build1
- 1.16.0+~1.14.4-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-follow-redirects Ubuntu:Pro:26.04:LTS
- Versions du logiciel
- 1.15.9+~1.14.4-1
- 1.15.11+~1.14.4-1build1
- 1.15.11+~1.14.4-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/follow-redirects/follow-redirects/security/advisories/GHSA-q3jh-wrc6-jgq8
- https://github.com/follow-redirects/follow-redirects/commit/9865ca45490e4d0f7b6944870318408344570aff
- https://github.com/follow-redirects/follow-redirects/releases/tag/v1.16.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-111756