p PatchFirst

CVE-2026-114612

CVE-2026-114612 · LiteLLM: Privilege Escalation to Proxy Admin via Cross-Domain Reuse of the Salt Key

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From 1.87.0 until 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2, the proxy reuses one cryptographic context for at-rest secrets and session tokens, allowing an authenticated internal user to have crafted metadata containing a forged administrator credential encrypted and returned by the API-key flow. Replaying that ciphertext as a bearer token causes the proxy to trust the forged proxy administrator identity, permitting administrative access and arbitrary commands through the MCP stdio endpoint. Versions 1.87.0 through 1.90.x require EXPERIMENTAL_UI_LOGIN to be enabled, while versions after 1.91.0 are exploitable in the default configuration. This issue was fixed in LiteLLM 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2.

CVSS 9.9 · Critique · EPSS 0,3% · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • litellm

    Versions du logiciel
    • >= 1.87.0, < 1.100.4: Concernée
    • >= 1.101.0, < 1.101.3: Concernée
    • >= 1.102.0, < 1.102.2: Concernée
    • >= 1.103.0, < 1.103.1: Concernée
    • >= 1.104.0-rc.1, < 1.104.0-rc.2: Concernée

    Aucun correctif publié

  • litellm PyPI

    Versions du logiciel
    • 1.100.0
    • 1.100.0.dev1
    • 1.100.0.dev2
    • 1.100.0rc1
    • 1.100.1
    • 1.100.2
    • 1.100.3
    • 1.91.0
    • 1.91.1
    • 1.91.2
    • 1.91.3
    • 1.91.4
    • 1.91.5
    • 1.92.0
    • 1.92.0.dev1
    • 1.92.0.dev2
    • 1.92.0rc1
    • 1.92.0rc2
    • 1.92.1
    • 1.92.2
    • 1.93.0
    • 1.93.0.dev1
    • 1.93.0.dev2
    • 1.93.0.dev3
    • 1.93.0rc1
    • 1.93.0rc2
    • 1.93.1
    • 1.93.2
    • 1.94.0
    • 1.94.0.dev3
    • 1.94.0rc1
    • 1.94.0rc2
    • 1.94.0rc3
    • 1.94.1
    • 1.94.2
    • 1.94.3
    • 1.95.0
    • 1.95.0.dev3
    • 1.95.0rc1
    • 1.95.0rc2
    • 1.95.0rc3
    • 1.95.1
    • 1.96.0
    • 1.96.0.dev2
    • 1.96.0rc1
    • 1.96.2
    • 1.97.0
    • 1.97.0.dev1
    • 1.97.0rc1
    • 1.98.0
    • 1.98.0.dev1
    • 1.98.0.dev2
    • 1.98.0rc1
    • 1.98.1
    • 1.99.0
    • 1.99.0.dev1
    • 1.99.0.dev2
    • 1.99.0rc1
    • 1.99.0rc2
    • 1.99.2
    • 1.99.3
    • 1.99.4
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.91.0, < 1.100.4

    Mettez à jour vers 1.100.4

  • litellm PyPI

    Versions du logiciel
    • 1.101.0
    • 1.101.1
    • 1.101.2
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.101.0, < 1.101.3

    Mettez à jour vers 1.101.3

  • litellm PyPI

    Versions du logiciel
    • 1.102.0
    • 1.102.1
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.102.0, < 1.102.2

    Mettez à jour vers 1.102.2

  • litellm PyPI

    Versions du logiciel
    • 1.103.0
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.103.0, < 1.103.1

    Mettez à jour vers 1.103.1

  • litellm PyPI

    Versions du logiciel
    • 1.104.0rc1
    Plages de versions concernées
    • ECOSYSTEM: ≥ 1.104.0rc1, < 1.104.0rc2

    Mettez à jour vers 1.104.0rc2

Sources originales

Vérifiez votre serveur →