CVE-2026-116575
CVE-2026-116575 · Mem0: Cross-tenant conversation leak via unescaped delimiter collision in session-scope key (_build_session_scope)
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Mem0 provides persistent memory infrastructure for AI agents and applications. Prior to Python SDK 2.0.18 and TypeScript SDK 3.1.6, _build_session_scope() in mem0/memory/main.py and Memory.buildSessionScope() in the TypeScript SDK join caller-controlled user_id, agent_id, and run_id values using unescaped & and = delimiters. A caller can embed another scope component in a controlled identifier so that distinct tenant tuples produce the same session_scope key. Memory.add(), AsyncMemory.add(), and the REST POST /memories flow use that key to read and save recent raw messages, allowing cross-tenant conversation disclosure and eviction or interleaving of another tenant's history. This issue is fixed in Python SDK 2.0.18 and TypeScript SDK 3.1.6.
CVSS 6.3 · Moyenne · EPSS 0,1% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: python · node
Produits et versions concernés
mem0
- Versions du logiciel
- < 2.0.18: Concernée
Aucun correctif publié
mem0ai PyPI
- Versions du logiciel
- 0.0.1
- 0.0.10
- 0.0.11
- 0.0.12
- 0.0.13
- 0.0.14
- 0.0.15
- 0.0.16
- 0.0.17
- 0.0.18
- 0.0.19
- 0.0.2
- 0.0.20
- 0.0.20rc1
- 0.0.21
- 0.0.3
- 0.0.4
- 0.0.5
- 0.0.6
- 0.0.7
- 0.0.8
- 0.0.9
- 0.1.0
- 0.1.1
- 0.1.10
- 0.1.100
- 0.1.101
- 0.1.102
- 0.1.103
- 0.1.104
- 0.1.106
- 0.1.107
- 0.1.107rc1
- 0.1.107rc2
- 0.1.108
- 0.1.109
- 0.1.11
- 0.1.110
- 0.1.111
- 0.1.112
- 0.1.113
- 0.1.114
- 0.1.115
- 0.1.116
- 0.1.117
- 0.1.118
- 0.1.12
- 0.1.13
- 0.1.14
- 0.1.15
- 0.1.16
- 0.1.17
- 0.1.18
- 0.1.19
- 0.1.2
- 0.1.20
- 0.1.20a0
- 0.1.21
- 0.1.22
- 0.1.23
- 0.1.24
- 0.1.25
- 0.1.26
- 0.1.27
- 0.1.28
- 0.1.29
- 0.1.3
- 0.1.30
- 0.1.31
- 0.1.32
- 0.1.33
- 0.1.34
- 0.1.35
- 0.1.36
- 0.1.37
- 0.1.38
- 0.1.39
- 0.1.4
- 0.1.40
- 0.1.41
- 0.1.42
- 0.1.43
- 0.1.44
- 0.1.45
- 0.1.45rc1
- 0.1.46
- 0.1.47
- 0.1.48
- 0.1.49
- 0.1.5
- 0.1.50
- 0.1.52
- 0.1.53
- 0.1.54
- 0.1.55
- 0.1.56
- 0.1.57
- 0.1.58
- 0.1.59
- 0.1.6
- 0.1.60
- 0.1.61
- 0.1.62
- 0.1.63
- 0.1.65
- 0.1.66
- 0.1.67
- 0.1.69
- 0.1.7
- 0.1.70
- 0.1.71
- 0.1.72
- 0.1.73
- 0.1.74
- 0.1.75
- 0.1.76
- 0.1.77
- 0.1.78
- 0.1.78a0
- 0.1.78a1
- 0.1.78a2
- 0.1.79
- 0.1.8
- 0.1.80
- 0.1.81
- 0.1.81a0
- 0.1.81a1
- 0.1.81a2
- 0.1.82
- 0.1.83
- 0.1.84
- 0.1.84a1
- 0.1.85
- 0.1.86
- 0.1.87
- 0.1.88
- 0.1.89
- 0.1.9
- 0.1.90
- 0.1.91
- 0.1.92
- 0.1.93
- 0.1.94
- 0.1.95
- 0.1.96
- 0.1.96rc1
- 0.1.97
- 0.1.98
- 0.1.99
- 0.1.99a0
- 0.1.99a1
- 0.1.99a2
- 0.1.99a3
- 1.0.0
- 1.0.0b0
- 1.0.1
- 1.0.10
- 1.0.11
- 1.0.2
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.0.8
- 1.0.9
- 2.0.0
- 2.0.0b0
- 2.0.0b1
- 2.0.0b2
- 2.0.1
- 2.0.10
- 2.0.11
- 2.0.12
- 2.0.13
- 2.0.14
- 2.0.15
- 2.0.16
- 2.0.17
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- Plages de versions concernées
- ECOSYSTEM: < 2.0.18
Mettez à jour vers 2.0.18
mem0ai npm
- Plages de versions concernées
- SEMVER: < 3.1.6
Mettez à jour vers 3.1.6
Sources originales
- https://github.com/mem0ai/mem0/security/advisories/GHSA-5324-3w58-qpp2
- https://github.com/mem0ai/mem0/pull/6892
- https://github.com/mem0ai/mem0/commit/71f2ebefa3494da21550fb525216818776cde67f
- https://github.com/mem0ai/mem0/releases/tag/ts-v3.1.6
- https://github.com/mem0ai/mem0/releases/tag/v2.0.18
- https://nvd.nist.gov/vuln/detail/CVE-2026-116575