p PatchFirst

CVE-2026-22610

CVE-2026-22610 · Angular has XSS Vulnerability via Unsanitized SVG Script Attributes

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0, a cross-site scripting (XSS) vulnerability has been identified in the Angular Template Compiler. The vulnerability exists because Angular’s internal sanitization schema fails to recognize the href and xlink:href attributes of SVG <script> elements as a Resource URL context. This issue has been patched in versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0.

CVSS 8.5 · Élevée · EPSS 0,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • angular

    Versions du logiciel
    • >= 21.1.0-next.0, < 21.1.0-rc.0: Concernée
    • >= 21.0.0-next.0, < 21.0.7: Concernée
    • >= 20.0.0-next.0, < 20.3.16: Concernée
    • < 19.2.18: Concernée

    Aucun correctif publié

  • @angular/compiler npm

    Plages de versions concernées
    • SEMVER: ≥ 21.1.0-next.0, < 21.1.0-rc.0

    Mettez à jour vers 21.1.0-rc.0

  • @angular/core npm

    Plages de versions concernées
    • SEMVER: ≥ 21.1.0-next.0, < 21.1.0-rc.0

    Mettez à jour vers 21.1.0-rc.0

  • @angular/compiler npm

    Plages de versions concernées
    • SEMVER: ≥ 21.0.0-next.0, < 21.0.7

    Mettez à jour vers 21.0.7

  • @angular/core npm

    Plages de versions concernées
    • SEMVER: ≥ 21.0.0-next.0, < 21.0.7

    Mettez à jour vers 21.0.7

  • @angular/compiler npm

    Plages de versions concernées
    • SEMVER: ≥ 20.0.0-next.0, < 20.3.16

    Mettez à jour vers 20.3.16

  • @angular/core npm

    Plages de versions concernées
    • SEMVER: ≥ 20.0.0-next.0, < 20.3.16

    Mettez à jour vers 20.3.16

  • @angular/compiler npm

    Plages de versions concernées
    • SEMVER: ≥ 19.0.0-next.0, < 19.2.18

    Mettez à jour vers 19.2.18

  • @angular/core npm

    Plages de versions concernées
    • SEMVER: ≥ 19.0.0-next.0, < 19.2.18

    Mettez à jour vers 19.2.18

  • @angular/compiler npm

    Plages de versions concernées
    • SEMVER: ≤ 18.2.14

    Aucun correctif publié

  • @angular/core npm

    Plages de versions concernées
    • SEMVER: ≤ 18.2.14

    Aucun correctif publié

  • angular.js Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 1.2.28-1ubuntu2
    • 1.2.28-1ubuntu2+esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 1.5.10-1
    • 1.5.10-1ubuntu0.1~esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:Pro:20.04:LTS

    Versions du logiciel
    • 1.5.10-1
    • 1.7.9-1
    • 1.7.9-1ubuntu0.1~esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:22.04:LTS

    Versions du logiciel
    • 1.8.2-2
    • 1.8.2-2ubuntu0.1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:24.04:LTS

    Versions du logiciel
    • 1.8.3-1
    • 1.8.3-1ubuntu0.24.04.1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:25.10

    Versions du logiciel
    • 1.8.3-1
    • 1.8.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:26.10

    Versions du logiciel
    • 1.8.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • angular.js Ubuntu:26.04:LTS

    Versions du logiciel
    • 1.8.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →