CVE-2026-23495
CVE-2026-23495 · Pimcore's Admin Classic Bundle is Missing Function Level Authorization on "Predefined Properties" Listing
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Pimcore's Admin Classic Bundle provides a Backend UI for Pimcore. Prior to 2.2.3 and 1.7.16, the API endpoint for listing Predefined Properties in the Pimcore platform lacks adequate server-side authorization checks. Predefined Properties are configurable metadata definitions (e.g., name, key, type, default value) used across documents, assets, and objects to standardize custom attributes and improve editorial workflows, as documented in Pimcore's official properties guide. Testing confirmed that an authenticated backend user without explicit permissions for property management could successfully call the endpoint and retrieve the complete list of these configurations. The vulnerability is fixed in 2.2.3 and 1.7.16.
CVSS 4.3 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: php
Produits et versions concernés
pimcore
- Versions du logiciel
- >= 2.0.0-RC1, < 2.2.3: Concernée
- < 1.7.16: Concernée
Aucun correctif publié
pimcore/admin-ui-classic-bundle Packagist
- Versions du logiciel
- 2.0.0-RC2
- v2.0.0
- v2.0.0-RC1
- v2.0.0-RC3
- v2.0.0-RC4
- v2.0.1
- v2.0.2
- v2.1.0
- v2.1.1
- v2.1.2
- v2.1.3
- v2.1.4
- v2.2.0
- v2.2.1
- v2.2.2
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.0.0-RC1, < 2.2.3
Mettez à jour vers 2.2.3
pimcore/admin-ui-classic-bundle Packagist
- Versions du logiciel
- 1.4.0
- v1.0.0
- v1.0.0-BETA1
- v1.0.0-RC1
- v1.0.0-RC2
- v1.0.1
- v1.0.2
- v1.0.3
- v1.0.4
- v1.0.5
- v1.0.6
- v1.1.0
- v1.1.0-RC1
- v1.1.1
- v1.1.2
- v1.1.3
- v1.1.4
- v1.2
- v1.2.0-RC1
- v1.2.1
- v1.2.2
- v1.2.3
- v1.3.0
- v1.3.0-RC1
- v1.3.1
- v1.3.2
- v1.3.3
- v1.3.4
- v1.3.5
- v1.4.1
- v1.4.2
- v1.4.3
- v1.4.4
- v1.4.5
- v1.5.0
- v1.5.0-RC1
- v1.5.0-RC2
- v1.5.1
- v1.5.2
- v1.5.3
- v1.5.4
- v1.5.5
- v1.6.0
- v1.6.0-RC1
- v1.6.0-RC2
- v1.6.1
- v1.6.2
- v1.6.3
- v1.6.4
- v1.6.5
- v1.6.6
- v1.7.0
- v1.7.1
- v1.7.10
- v1.7.12
- v1.7.13
- v1.7.14
- v1.7.15
- v1.7.2
- v1.7.3
- v1.7.4
- v1.7.5
- v1.7.6
- v1.7.7
- v1.7.8
- v1.7.9
- Plages de versions concernées
- ECOSYSTEM: < 1.7.16
Mettez à jour vers 1.7.16
Sources originales
- https://github.com/pimcore/pimcore/security/advisories/GHSA-hqrp-m84v-2m2f
- https://github.com/pimcore/admin-ui-classic-bundle/commit/98095949fbeaf11cdf4cadb2989d7454e1b88909
- https://github.com/pimcore/admin-ui-classic-bundle/releases/tag/v1.7.16
- https://github.com/pimcore/admin-ui-classic-bundle/releases/tag/v2.2.3
- https://nvd.nist.gov/vuln/detail/CVE-2026-23495