p PatchFirst

CVE-2026-23643

CVE-2026-23643 · CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.

CVSS 5.4 · Moyenne · EPSS 0,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · php

Produits et versions concernés

  • cakephp

    Versions du logiciel
    • >= 5.2.10, < 5.2.12: Concernée
    • >= 5.3.0, < 5.3.1: Concernée

    Aucun correctif publié

  • cakephp/cakephp Packagist

    Versions du logiciel
    • 5.2.10
    • 5.2.11
    Plages de versions concernées
    • ECOSYSTEM: ≥ 5.2.10, < 5.2.12

    Mettez à jour vers 5.2.12

  • cakephp/cakephp Packagist

    Versions du logiciel
    • 5.3.0
    Plages de versions concernées
    • ECOSYSTEM: ≥ 5.3.0, < 5.3.1

    Mettez à jour vers 5.3.1

  • cakephp Ubuntu:16.04:LTS

    Versions du logiciel
    • 2.7.2-1
    • 2.8.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • cakephp Ubuntu:20.04:LTS

    Versions du logiciel
    • 2.10.11-2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • cakephp Ubuntu:22.04:LTS

    Versions du logiciel
    • 2.10.11-2.1
    • 2.10.24-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →