CVE-2026-24778
CVE-2026-24778 · Ghost vulnerable to XSS via malicious Portal preview links
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Ghost is an open source content management system. In Ghost versions 5.43.0 through 5.12.04 and 6.0.0 through 6.14.0, an attacker was able to craft a malicious link that, when accessed by an authenticated staff user or member, would execute JavaScript with the victim's permissions, potentially leading to account takeover. Ghost Portal versions 2.29.1 through 2.51.4 and 2.52.0 through 2.57.0 were vulnerable to this issue. Ghost automatically loads the latest patch of the members Portal component via CDN. For Ghost 5.x users, upgrading to v5.121.0 or later fixes the vulnerability. v5.121.0 loads Portal v2.51.5, which contains the patch. For Ghost 6.x users, upgrading to v6.15.0 or later fixes the vulnerability. v6.15.0 loads Portal v2.57.1, which contains the patch. For Ghost installations using a customized or self-hosted version of Portal, it will be necessary to manually rebuild from or update to the latest patch version.
CVSS 8.8 · Élevée · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: node
Produits et versions concernés
ghost
- Versions du logiciel
- @tryghost/portal >= 2.29.1, < 2.51.5: Concernée
- @tryghost/portal >= 2.52.0, < 2.57.1: Concernée
- ghost >= 5.43.0, < 5.121.0: Concernée
- ghost >= 6.0.0, < 6.15.0: Concernée
Aucun correctif publié
ghost npm
- Plages de versions concernées
- SEMVER: ≥ 5.43.0, < 5.121.0
Mettez à jour vers 5.121.0
@tryghost/portal npm
- Plages de versions concernées
- SEMVER: ≥ 2.29.1, < 2.51.5
Mettez à jour vers 2.51.5
@tryghost/portal npm
- Plages de versions concernées
- SEMVER: ≥ 2.52.0, < 2.57.1
Mettez à jour vers 2.57.1
ghost npm
- Plages de versions concernées
- SEMVER: ≥ 6.0.0, < 6.15.0
Mettez à jour vers 6.15.0