CVE-2026-25075
CVE-2026-25075 · strongSwan 4.5.0 < 6.0.5 EAP-TTLS AVP Parsing Integer Underflow
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
strongSwan versions 4.5.0 prior to 6.0.5 contain an integer underflow vulnerability in the EAP-TTLS AVP parser that allows unauthenticated remote attackers to cause a denial of service by sending crafted AVP data with invalid length fields during IKEv2 authentication. Attackers can exploit the failure to validate AVP length fields before subtraction to trigger excessive memory allocation or NULL pointer dereference, crashing the charon IKE daemon.
CVSS 8.7 · Élevée · EPSS 1,1% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
strongswan
- Versions du logiciel
- ≥ 4.5.0, < 6.0.5: Concernée (semver)
Mettez à jour vers 6.0.5
strongswan Debian:12
- Versions du logiciel
- 5.9.8-5
- 5.9.8-5+deb12u1
- 5.9.8-5+deb12u2
- Plages de versions concernées
- ECOSYSTEM: < 5.9.8-5+deb12u3
Mettez à jour vers 5.9.8-5+deb12u3
strongswan Debian:13
- Versions du logiciel
- 6.0.1-6
- 6.0.1-6+deb13u1
- 6.0.1-6+deb13u2
- Plages de versions concernées
- ECOSYSTEM: < 6.0.1-6+deb13u4
Mettez à jour vers 6.0.1-6+deb13u4
strongswan Debian:14
- Versions du logiciel
- 6.0.1-6
- 6.0.2-1
- 6.0.3-1
- 6.0.4-1
- Plages de versions concernées
- ECOSYSTEM: < 6.0.5-1
Mettez à jour vers 6.0.5-1
strongswan Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 4.6.4-9
- 5.1.0-2
- 5.1.0-3
- 5.1.1-0ubuntu1
- 5.1.1-0ubuntu2
- 5.1.1-0ubuntu3
- 5.1.1-0ubuntu4
- 5.1.1-0ubuntu5
- 5.1.1-0ubuntu7
- 5.1.1-0ubuntu14
- 5.1.1-0ubuntu17
- 5.1.2~dr3+git20130120-0ubuntu2
- 5.1.2~dr3+git20130120-0ubuntu3
- 5.1.2~rc1-0ubuntu3
- 5.1.2~rc1-0ubuntu4
- 5.1.2~rc2-0ubuntu2
- 5.1.2-0ubuntu1
- 5.1.2-0ubuntu2
- 5.1.2-0ubuntu2.2
- 5.1.2-0ubuntu2.3
- 5.1.2-0ubuntu2.4
- 5.1.2-0ubuntu2.5
- 5.1.2-0ubuntu2.6
- 5.1.2-0ubuntu2.7
- 5.1.2-0ubuntu2.8
- 5.1.2-0ubuntu2.10
- 5.1.2-0ubuntu2.11
- 5.1.2-0ubuntu2.11+esm1
- 5.1.2-0ubuntu2.11+esm2
- 5.1.2-0ubuntu2.11+esm3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 5.1.2-0ubuntu6
- 5.1.2-0ubuntu7
- 5.1.2-0ubuntu8
- 5.3.5-1ubuntu1
- 5.3.5-1ubuntu2
- 5.3.5-1ubuntu3
- 5.3.5-1ubuntu3.1
- 5.3.5-1ubuntu3.2
- 5.3.5-1ubuntu3.3
- 5.3.5-1ubuntu3.4
- 5.3.5-1ubuntu3.5
- 5.3.5-1ubuntu3.7
- 5.3.5-1ubuntu3.8
- 5.3.5-1ubuntu3.8+esm1
- 5.3.5-1ubuntu3.8+esm2
- 5.3.5-1ubuntu3.8+esm3
- 5.3.5-1ubuntu3.8+esm4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:Pro:FIPS-updates:16.04:LTS
- Versions du logiciel
- 5.3.5-1ubuntu3.fips.3.4.1
- 5.3.5-1ubuntu3.fips.3.4.2
- 5.3.5-1ubuntu3.fips.3.8.1
- 5.3.5-1ubuntu3.fips.3.8.2
- 5.3.5-1ubuntu3.fips.3.8.3
- 5.3.5-1ubuntu3.fips.3.8.6
- 5.3.5-1ubuntu3.fips.3.8.7
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:Pro:FIPS:16.04:LTS
- Versions du logiciel
- 5.3.5-1ubuntu3.fips.3.1
- 5.3.5-1ubuntu3.fips.3.2
- 5.3.5-1ubuntu3.fips.3.3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 5.5.1-4ubuntu2
- 5.5.1-4ubuntu3
- 5.6.1-2ubuntu1
- 5.6.1-2ubuntu2
- 5.6.1-2ubuntu3
- 5.6.1-2ubuntu4
- 5.6.2-1ubuntu2
- 5.6.2-1ubuntu2.2
- 5.6.2-1ubuntu2.3
- 5.6.2-1ubuntu2.4
- 5.6.2-1ubuntu2.5
- 5.6.2-1ubuntu2.6
- 5.6.2-1ubuntu2.7
- 5.6.2-1ubuntu2.8
- 5.6.2-1ubuntu2.9
- 5.6.2-1ubuntu2.9+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:Pro:FIPS-updates:18.04:LTS
- Versions du logiciel
- 5.6.2-1ubuntu2.fips.2.5.1
- 5.6.2-1ubuntu2.fips.2.7.1
- 5.6.2-1ubuntu2.fips.2.7.2
- 5.6.2-1ubuntu2.fips.2.8.1
- 5.6.2-1ubuntu2.fips.2.9
- 5.6.2-1ubuntu2.fips.2.9+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:Pro:FIPS:18.04:LTS
- Versions du logiciel
- 5.6.2-1ubuntu2.fips.2.4.2
- 5.6.2-1ubuntu2.fips.2.5.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:20.04:LTS
- Versions du logiciel
- 5.7.2-1ubuntu3
- 5.8.1-1ubuntu1
- 5.8.2-1ubuntu1
- 5.8.2-1ubuntu2
- 5.8.2-1ubuntu3
- 5.8.2-1ubuntu3.1
- 5.8.2-1ubuntu3.2
- 5.8.2-1ubuntu3.3
- 5.8.2-1ubuntu3.4
- 5.8.2-1ubuntu3.5
- 5.8.2-1ubuntu3.6
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:Pro:FIPS-updates:20.04:LTS
- Versions du logiciel
- 5.8.2-1ubuntu3.fips.3.1.2
- 5.8.2-1ubuntu3.fips.3.3.1
- 5.8.2-1ubuntu3.fips.3.4.1
- 5.8.2-1ubuntu3.fips.3.5
- 5.8.2-1ubuntu3.fips.3.6
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:Pro:FIPS:20.04:LTS
- Versions du logiciel
- 5.8.2-1ubuntu3.fips.3.1.2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:22.04:LTS
- Versions du logiciel
- 5.9.1-1ubuntu3
- 5.9.1-1ubuntu3.1
- 5.9.4-1ubuntu1
- 5.9.4-1ubuntu2
- 5.9.4-1ubuntu3
- 5.9.4-1ubuntu4
- 5.9.5-2ubuntu1
- 5.9.5-2ubuntu2
- 5.9.5-2ubuntu2.1
- 5.9.5-2ubuntu2.2
- 5.9.5-2ubuntu2.3
- 5.9.5-2ubuntu2.4
- Plages de versions concernées
- ECOSYSTEM: < 5.9.5-2ubuntu2.5
Mettez à jour vers 5.9.5-2ubuntu2.5
strongswan Ubuntu:Pro:FIPS-preview:22.04:LTS
- Versions du logiciel
- 5.9.5-2ubuntu2.1+Fips1
- 5.9.5-2ubuntu2.2+Fips1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
strongswan Ubuntu:Pro:FIPS-updates:22.04:LTS
- Versions du logiciel
- 5.9.5-2ubuntu2.1+Fips1
- 5.9.5-2ubuntu2.2+Fips1
- 5.9.5-2ubuntu2.3+Fips1
- 5.9.5-2ubuntu2.4+Fips1
- Plages de versions concernées
- ECOSYSTEM: < 5.9.5-2ubuntu2.5+Fips1
Mettez à jour vers 5.9.5-2ubuntu2.5+Fips1
strongswan Ubuntu:24.04:LTS
- Versions du logiciel
- 5.9.11-1ubuntu1
- 5.9.11-1ubuntu2
- 5.9.12-1ubuntu1
- 5.9.13-2ubuntu1
- 5.9.13-2ubuntu3
- 5.9.13-2ubuntu4
- 5.9.13-2ubuntu4.24.04.1
- Plages de versions concernées
- ECOSYSTEM: < 5.9.13-2ubuntu4.24.04.2
Mettez à jour vers 5.9.13-2ubuntu4.24.04.2
strongswan Ubuntu:25.10
- Versions du logiciel
- 5.9.13-2ubuntu4
- 5.9.13-2ubuntu5
- 6.0.1-6ubuntu2
- 6.0.1-6ubuntu4
- 6.0.1-6ubuntu4.1
- Plages de versions concernées
- ECOSYSTEM: < 6.0.1-6ubuntu4.2
Mettez à jour vers 6.0.1-6ubuntu4.2
Sources originales
- https://www.strongswan.org/blog/2026/03/23/strongswan-vulnerability-(cve-2026-25075).html
- https://www.strongswan.org/blog/2026/03/23/strongswan-6.0.5-released.html
- https://y637f9qq2x.com/posts/cve-2026-25075/
- https://www.vulncheck.com/advisories/strongswan-eap-ttls-avp-parsing-integer-underflow
- https://lists.debian.org/debian-lts-announce/2026/03/msg00016.html
- https://nvd.nist.gov/vuln/detail/CVE-2026-25075