p PatchFirst

CVE-2026-2673

CVE-2026-2673 · OpenSSL TLS 1.3 server may choose unexpected key agreement group

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Issue summary: An OpenSSL TLS 1.3 server may fail to negotiate the expected preferred key exchange group when its key exchange group configuration includes the default by using the 'DEFAULT' keyword. Impact summary: A less preferred key exchange may be used even when a more preferred group is supported by both client and server, if the group was not included among the client's initial predicated keyshares. This will sometimes be the case with the new hybrid post-quantum groups, if the client chooses to defer their use until specifically requested by the server. If an OpenSSL TLS 1.3 server's configuration uses the 'DEFAULT' keyword to interpolate the built-in default group list into its own configuration, perhaps adding or removing specific elements, then an implementation defect causes the 'DEFAULT' list to lose its 'tuple' structure, and all server-supported groups were treated as a single sufficiently secure 'tuple', with the server not sending a Hello Retry Request (HRR) even when a group in a more preferred tuple was mutually supported. As a result, the client and server might fail to negotiate a mutually supported post-quantum key agreement group, such as 'X25519MLKEM768', if the client's configuration results in only 'classical' groups (such as 'X25519' being the only ones in the client's initial keyshare prediction). OpenSSL 3.5 and later support a new syntax for selecting the most preferred TLS 1.3 key agreement group on TLS servers. The old syntax had a single 'flat' list of groups, and treated all the supported groups as sufficiently secure. If any of the keyshares predicted by the client were supported by the server the most preferred among these was selected, even if other groups supported by the client, but not included in the list of predicted keyshares would have been more preferred, if included. The new syntax partitions the groups into distinct 'tuples' of roughly equivalent security. Within each tuple the most preferred group included among the client's predicted keyshares is chosen, but if the client supports a group from a more preferred tuple, but did not predict any corresponding keyshares, the server will ask the client to retry the ClientHello (by issuing a Hello Retry Request or HRR) with the most preferred mutually supported group. The above works as expected when the server's configuration uses the built-in default group list, or explicitly defines its own list by directly defining the various desired groups and group 'tuples'. No OpenSSL FIPS modules are affected by this issue, the code in question lies outside the FIPS boundary. OpenSSL 3.6 and 3.5 are vulnerable to this issue. OpenSSL 3.6 users should upgrade to OpenSSL 3.6.2 once it is released. OpenSSL 3.5 users should upgrade to OpenSSL 3.5.6 once it is released. OpenSSL 3.4, 3.3, 3.0, 1.0.2 and 1.1.1 are not affected by this issue.

CVSS 6.5 · Moyenne · EPSS 0,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · network

Produits et versions concernés

  • openssl

    Versions du logiciel
    • ≥ 3.6.0, < 3.6.2: Concernée (semver)
    • ≥ 3.5.0, < 3.5.6: Concernée (semver)

    Mettez à jour vers 3.5.6; Mettez à jour vers 3.6.2

  • openssl Debian:13

    Versions du logiciel
    • 3.5.1-1
    • 3.5.1-1+deb13u1
    • 3.5.2-1
    • 3.5.3-1
    • 3.5.4-1
    • 3.5.4-1~deb13u1
    • 3.5.4-1~deb13u2
    • 3.5.5-1~deb13u1
    Plages de versions concernées
    • ECOSYSTEM: < 3.5.5-1~deb13u2

    Mettez à jour vers 3.5.5-1~deb13u2

  • openssl Debian:14

    Versions du logiciel
    • 3.5.1-1
    • 3.5.2-1
    • 3.5.3-1
    • 3.5.4-1
    • 3.5.4-1~deb13u1
    • 3.5.4-1~deb13u2
    • 3.5.5-1
    • 3.5.5-1~deb13u1
    • 3.5.5-1~deb13u2
    • 3.5.6-1~deb13u1
    • 3.5.6-1~deb13u2
    • 3.5.7-1~deb13u1
    • 3.5.7-1~deb13u2
    • 3.5.7-1~deb13u3
    • 3.6.0-1
    • 3.6.0-2
    • 3.6.0~~alpha1-1
    • 3.6.0~~beta1-1
    • 3.6.1-1
    • 3.6.1-2
    • 3.6.1-3
    Plages de versions concernées
    • ECOSYSTEM: < 3.6.2-1

    Mettez à jour vers 3.6.2-1

  • nodejs Ubuntu:Pro:22.04:LTS

    Versions du logiciel
    • 12.22.5~dfsg-5ubuntu1
    • 12.22.7~dfsg-2ubuntu1
    • 12.22.7~dfsg-2ubuntu3
    • 12.22.9~dfsg-1ubuntu2
    • 12.22.9~dfsg-1ubuntu3
    • 12.22.9~dfsg-1ubuntu3.1
    • 12.22.9~dfsg-1ubuntu3.2
    • 12.22.9~dfsg-1ubuntu3.3
    • 12.22.9~dfsg-1ubuntu3.4
    • 12.22.9~dfsg-1ubuntu3.5
    • 12.22.9~dfsg-1ubuntu3.6
    • 12.22.9~dfsg-1ubuntu3.6+esm2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • openssl Ubuntu:25.10

    Versions du logiciel
    • 3.4.1-1ubuntu3
    • 3.5.0-2ubuntu1
    • 3.5.2-1ubuntu1
    • 3.5.3-1ubuntu2
    • 3.5.3-1ubuntu3
    Plages de versions concernées
    • ECOSYSTEM: < 3.5.3-1ubuntu3.3

    Mettez à jour vers 3.5.3-1ubuntu3.3

  • openssl Ubuntu:26.10

    Plages de versions concernées
    • ECOSYSTEM: < 3.5.5-1ubuntu3

    Mettez à jour vers 3.5.5-1ubuntu3

  • openssl Ubuntu:26.04:LTS

    Versions du logiciel
    • 3.5.3-1ubuntu2
    • 3.5.5-1ubuntu1
    Plages de versions concernées
    • ECOSYSTEM: < 3.5.5-1ubuntu3

    Mettez à jour vers 3.5.5-1ubuntu3

Sources originales

Vérifiez votre serveur →