p PatchFirst

CVE-2026-27210

CVE-2026-27210 · Pannellum has a XSS vulnerability in hot spot attributes

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Pannellum is a lightweight, free, and open source panorama viewer for the web. In versions 3.5.0 through 2.5.6, the hot spot attributes configuration property allowed any attribute to be set, including HTML event handler attributes, allowing for potential XSS attacks. This affects websites hosting the standalone viewer HTML file and any other use of untrusted JSON config files (bypassing the protections of the escapeHTML parameter). As certain events fire without any additional user interaction, visiting a standalone viewer URL that points to a malicious config file — without additional user interaction — is sufficient to trigger the vulnerability and execute arbitrary JavaScript code, which can, for example, replace the contents of the page with arbitrary content and make it appear to be hosted by the website hosting the standalone viewer HTML file. This issue has been fixed in version 2.5.7. To workaround, setting the Content-Security-Policy header to script-src-attr 'none' will block execution of inline event handlers, mitigating this vulnerability. Don't host pannellum.htm on a domain that shares cookies with user authentication to mitigate XSS risk.

CVSS 5.3 · Moyenne · EPSS 0,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • pannellum

    Versions du logiciel
    • >= 2.5.0, < 2.5.7: Concernée

    Aucun correctif publié

  • pannellum npm

    Plages de versions concernées
    • SEMVER: ≥ 2.5.0, < 2.5.7

    Mettez à jour vers 2.5.7

Sources originales

Vérifiez votre serveur →